Pihat keeps rebooting picade

So I have found if I removed the pihat it works fine. Of course just not as a picade lol.

As soon as it is connected it boots but then the white LED turns off and the pi reboots and then comes back online :(

Makes this useless. Please help.

I have removed all items plugged into the picade hat and then connected it to the Pi and it still reboots the pi after 20-40 seconds.

While it was removed I was able to install the picade hat drivers with no issues so it has the drivers installed. And it will be stable and no reboots when no hat is installed.

Do you have heatsinks on the Pi? Make sure the bottom of the Picade X Hat isn’t touching anything on the Pi.

I have no heatsinks.

I also found is I power through the pi directly that I can connect the HAT and it stays running (no reboots). But I don’t get the front and side buttons to work.

As soon as I run the power through the picade hat again (nothing else changes) it starts to reboot every 20 seconds.

Also the plasma buttons do not light the last three buttons. I mean the have a weird color but they are not part of the rainbow pattern.

I am pulling my hair out here. I have built many pi based handhelds and never had this kind of issue before. :(

I got the lights in the buttons working. Was a shitty made cable. It has two cables plugged into the cable plug that had strands of loose copper touching each other.

But the damn thing still keeps rebooting. Plays 20 seconds of the intro video then bam reboots. And does the same thing over and over. And over and over.

Using the pi power supply and everything.

I can power the pi directly and it works but I have no sound and the front/side buttons are not seen. Wth.

Please help pimoroni!!!

Powering through the pi I got most everything working. But the audio is at max volume and I can’t get the audio controls to work at all. The non working buttons were again crappy wires that have severed cables on the ends that go into the header in the hat.

So it seems to be almost working but audio is jacked (getting the mixer not found error, and going to the audio settings in rasp config just kicks me back to the main menu for rasp config. )

Still not sure why I can’t power this from the hat as the way it is plugged in now is not workable honestly.

I ordered a canakit power supply as they are a little over 5v and output 3.5A instead of 3A. Hoping it is just not enough powers even though it is the correct specified power supply.

Gah so many issues for something that should just work.

There must be an issue / defect with the Picade Hats power on off function.
I’d e-mail Pimoroni with a link to this thread and the other thread on the plasma lights.
Contact Us for Raspberry Pi Technical Support – Pimoroni

But if I remove the buttons from the inputs it still does it.

I’ll email them again. Thanks.

Still no reply from support email days later makes me sad

I’ll give this a try, he is as far as I know staff. @Matt

Thanks! Let’s see what happens :)

Hi,

It seems I am having the exact same problem. Constantly reboots every 15-20 seconds but if i power the Pi directly i have no problems.

Did you get any help on this?

One option is to post it as an issue on its GitHub page.
Issues · pimoroni/picade-hat · GitHub

EDIT: Just for the record, I don’t work for or have any affiliation with Pimoroni. I only mention it because I’m here a lot and post a lot. It wouldn’t be a big stretch to think I was part of the team. I’m just another enthusiast trying to help out when I can.

Thanks Alpha, and understood.

Anyway, i tried a clean retropie build and it worked so assumed it was the image i had been using. I fresh install of it and the picade drivers seems to have it working for now.

cheers

john

The Picade Hat does have a shutdown function, something must have messed up that bit of software or was messing with the GPIO pin that triggers it?

Hey guys. I had the same issue using a custom build image.

I was googling with no sucess as well but signed up to this forum when I found the fix.
I was the same, a new image of picade would work fine without rebooting but others would reboot after 20-30 seconds so I knew it was software and not hardware.
I also noticed that it would only reboot if the picade was powered via the picade x hat and not directly via the pi.

However, it seems to be down to some options specified in the /boot/config.txt

I compared the two files from the base working image and the custom image I was using.
There were a few differences.

dtparam=i2c_arm=on was uncommented in the failing image but commented in the working image. I beleive this can mess with GPIO pins so I commented it. I think this is the most likley culprit.

There were a few others but I think thats the most likley. If in doubt, just copy over the working /boot/config.txt from a working base image after you have installed the xhat drivers on it.

My PI now works fine without rebooting using the power on the xhat.

I hope this helps you and others googling.

  • Fazza

GPIO 4 is the shutdown pin used. And the Picade Hat doesn’t use or need i2c so.
#dtparam=i2c_arm=on
or
dtparam=i2c_arm=off
is the way to go.

Picade X HAT at Raspberry Pi GPIO Pinout

1 Like