The Picade Hat


#1

This might be a daft question but is the PICADE Hat only for when you are running Retropie?

It’s just that I ordered one and purchased it mainly to use the power on and off option. I have a project that I am using a five button joystick to display photographs. My code automatically boots up from power on.
Can I still use the Picade hat even though I am not running Retropie?


#2

Absolutely. There’s nothing specific about Picade HAT that requires RetroPie. You can even ignore our software installer and write your own Python code to use it directly if you don’t need the keypress emulation.


#3

the installer will tell you that retropie is not installed but will do the exact same job as if it were. But as @gadgetoid said you don’t have to use our software stack in any case.

In fact, the HAT EEPROM contains the gpio-poweroff routine and will automatically suspend power when you call a shutdown. Wire up a button to the power terminal and you should be good to go, no code needed (except calling the shutdown in your preferred manner).


#4

I am a bit confused at the moment regarding the operation of the power button on the picade hat.
.
I have wired a momentarily closed push button to the utility power terminal and ground on the picade hat.

The Raspberry pi will only boot up and have power if I keep the switch closed.
As soon as I open the switch the pi loses power.

It did this before I installed the Picade hat software as well.


#5

I remember @RogueM had exactly this problem, but I can’t for the life of me remember why.


#6

Aha, yes.

From @RogueM

Could you try the following:

  1. power the Pi via its own microUSB (not through the HAT)
  2. boot up then exit emulation station (F4) or otherwise access the command line
  3. navigate to ~/Pimoroni/picade/picade-hat/
  4. synchronize the repository with: git pull
  5. cd inside the ‘eeprom’ folder, and run: ./reflash.sh

… then shutdown, and try to power up the Pi through the HAT.


#7

Thankyou for your help after eventually understanding what it is you wanted to do ( my fault not yours) Your suggestions have solved my problem. Thank you.

I think the issue was that when I first installed the Picadehat software from the instructions on the website. The software was not installed correctly and the picade-hat folder was empty?

I noticed that after cloning the git hub filesto my Raspberry Pi it did not place them in a Pimoroni folder.

Anyway all good now thanks


#8

If you ran the reflash.sh in the eeprom folder, that will no doubt be what fixed it. We released an updated EEPROM configuration to get the power on/off functionality working properly. Sorry it caused you trouble!

Happy picading!


#9

Thanks for the help.
My next question is I have a Python code that uses five buttons to control a picture show and the buttons are connected directly to the GPIO and ground. So now wondering what buttons would I have to use in my code so I can connect them directly to the picade hat?

On my website below there is a Rasoberry Pi link in the menu which shows what I have built.

Dean Gale Photography


#10

I think it is great that you take the time to help solve people’s problems with your products. So many companies sell Raspberry peripherals but do not provide back up.

Once again thank you

Dean Gale Photography


#11

PS.
Isn’t it all way past your bed time in Sheffield?

Ex Loughborough lad living Down Under

Dean Gale Photography


#12

check out http://pinout.xyz/pinout/picade_hat for the button mapping to GPIO.