Raspberry Pi stuck on shutdown after installing Picade Hat


#1

HI

I’m running Retropie using Raspberry Pi 3 b + and a Picade HAT.

I followed the instructions to install the Picade drivers and now when I shut down it stays stuck and never completely shuts down. I keep having to force power off which I’m sure is not great in the long run.

It says [ .78.732326] reboot: power down

Any advice? How do I uninstall the Picade stuff?


#2

I solved it by entering the following commands:

sudo dpkg --list

Then when the list is complete I entered

sudo apt-get --purge remove picade

Now my Pi reboots normally. There’s definitely something screwy going on with Picade.


#3

How were you powering the setup? Through the Pi, or the Picade HAT?


#4

Through the Pi.

Having the same issue again now, I don’t think I managed to erase all the Picade files…


#5

You need to power it through the HAT for the power to actually be cut following a shutdown.

What do you actually see on the screen at the last stage of shutdown? Could you snap a photo?


#6


#7

This is pretty normal for a Pi- with or without Picade HAT- it wont actually power down because there’s no onboard power management circuitry to cut the power. That’s done by unplugging it manually. This is why it powers on as soon as you plug it in, and there’s no push-button on switch or anything.

Picade HAT adds this functionality, but you have to power the Pi through the Picade HAT so that the HAT can cut the power when it’s asked to.

Try reinstalling Picade HAT and swapping the microB power supply from the Pi, to the microB connector on the HAT itself. That should cut the power when shut down.


#8

I reinstalled Picade and switched the power supply, now nothing shows up on the screen.

Is there something I missed inbetween?

I’m not sure what you mean by there’s no push button. My power supply has an on/off button on it (PiSwitch)


#9

If you’re using Picade X HAT there’s a little push-button on the PCB to turn it on.


#10

It’s not an X Hat. What I purchased was a Picade HAT with kit parts, there are no buttons on it.


#11

On the original Picade HAT you need to wire a push-button to the power button terminal on the left. That then becomes your on/shutdown button.


#12

I couldn’t find anything on that. I have a button attached already but it’s not doing anything. Do I need to do something in Terminal.

Any other wiring? I see some holes on the right.


#13

Ok I figured out how it works now. The Power button now works as an on/off switch, I found a solution from a guide online.

The only remaining issue now is the wired speaker. I’m not getting any sound from it.