Please help - 12.1 display issue


#1

Hi, I’m tearing my hair out with a new Picade build using the Samsung LTN121XL01-N03 12.1 screen.

I bought a BYO Picade, Samsung screen from displaysscreen.com and LCD controller board from ebay (item number 162644054206).

The issue I’m having is with some sort of interference on the screen. On a specific area of the screen there are these stripes that move like an old 80’s Spectrum loading screen (sorry, that seemed best way to describe). This only happens on the area when its bright white. When I hit the SELECT button to turn on screensaver it disappears as the screen is slightly duller.

Here’s what I’ve tried so far -

  1. I’ve connected up the Picade to an external monitor and there are no issues on the monitor, all looks good.

  2. I’ve purchased 2 new power supplies with the recommended ratings and there is no difference.

  3. I’ve changed the settings on the startup so that the screen is HDMI with 4:3 and 1024x768 (2 and 16 if I remember correctly).

  4. I’ve tried a 2nd controller board from the same seller and it has the exact same results.

I’m at the end of my tether now as all this was bought in November and I was hoping to have it up and running for my son by Christmas (2017!).

Has anyone had any issues like this with this screen or would have any idea what could be causing this?

Choosing ZOOM mode through the TV controller board settings makes the problem disappear. As soon as I choose FULL or 4:3 the problem comes back. All the fonts look clear and sharp all the time without any image wobble like I’ve seen with other 12.1 issues on here.

I’ve attached a photo showing the issue.

Many thanks for reading.


#2

This isn’t something we’ve come across before. Do you see the same issue/distortion when you connect the display to any other HDMI source; a laptop or desktop computer for example?

Do you see the same distortion if you connect the Pi up to a TV?

It’s probably not the HDMI cable, but have you tried swapping it out with a different one?


#3

Hi, thanks for the response.

I’ve carried out further tests and can confirm the following -

Connecting only a laptop to the screen yields the same results, definitely ruling out the Picade, Pi, etc. as a potential cause of the problem (photo below).

Connecting up the Picade to a TV screen shows no issues again confirming the Picade, Pi, etc are all good.

I’ve tried two different HDMI cables, the short one that came with the Picade and another one that was lying around with no difference.

I’ve tried two completely different power supplies with correct ratings, etc with no difference.

So it really has to be the controller board or the screen and I’m already on the second controller board from the same seller in Hong Kong. The seller has really good feedback through selling driver boards although that obviously doesn’t mean there couldn’t be something wrong with both boards.

With regards to the screen itself, it doesn’t show any distortion at all when ZOOM mode is selected on the controller board and that’s still outputting at 1024x768 59.9hz. As soon as FULL or 4:3 is selected then the distortion is present. This seems to only present itself on light grey and blue colours.

I guess the only way I can confirm if its the controller board is if I try and source another board from another seller or if I can find someone with the same screen in a known working setup who could test my board for me.


#4

Presumably you’ve also replaced/reseated the ribbon between the controller board and display panel too?

I’m not sure this entirely rules out the display being at fault, though I am at a loss for what factor could cause the display itself to behave like this. It’s much more likely to be the control board. But then two exhibiting the same problem seems unlikely.

It’s very a strangely localised problem, looking at your screenshot. I’m afraid I don’t have any better ideas what might be wrong. I’ll see if anyone else might know.