PMS5003 No Output

Setting up an enviro+ with PMS5003.

After doing a pip install configparser, the installer seemed to work and all the sensors EXCEPT the PMS5003 (the main reason I bought the thing).

When I run the particulates example, all I see is “Press Ctrl-c to exit”.

If I run all-in-one, after a few taps, I see
Traceback (most recent call last):
File “all-in-one.py”, line 188, in
data = pms5003.read()
File “build/bdist.linux-armv6l/egg/pms5003/init.py”, line 121, in read
pms5003.ReadTimeoutError: PMS5003 Read Timeout

The fan is running on the PMS, but I can’t see anything beyond that

Help?

Found the solution - turns out that software is connected to /dev/ttyS0; but, the software is reading /dev/ttyAMA0.

So, as root:

mv /dev/ttyAMA0
ln /dev/ttyS0 /dev/ttyAMA0

Works like a champ.

Would still like to understand WHY…

I am so glad that you figured this out. I think that I am having the same problem.
All I get it this…
^Cpi@raspberrypi:~/enviroplus-python/examples $ python particulates.py
particulates.py - Print readings from the PMS5003 particulate sensor.
Press Ctrl+C to exit!
The trouble is that I am very new to python and am not sure how to implement your answer. Can anyone point me to some docs ?
Many Thanks

OMG So sorry , I rebooted and now it is working…