Problem getting Rockpool to work AT ALL!


#1

First experience with Raspberry Pi!

I have a Rasberry Pi 2 and got Jessie installed. I updated and upgraded.

I then used the terminal command:
curl get.pimoroni.com/rockpool | bash

to get the Rockpool code installed.

Rebooted.

When I try to launch pretty much anything on the Pi, it does not launch.

I can see the Rockpool menu item in Menu > Programming, but if I try to launch this, nothing happens.

Lots of other things behave in ways that I’d not expect - Epiphany force closes as soon as I enter a URL and click ‘return’. Mathematica issues a ‘Serious Startup Error’ saying that ‘The front end was unable to create the defaults directory /home/pi/.Mathematica.’

Do you think that there is a basic thing that I ought to be doing, which I’m not? Something that you frequent users know that I don’t.

I’ve tried x2 different SD cards and installed Jessie x2 on each of those SD cards just to make sure that it was not me having a bad download or dodgy hardware.

Thanks for any and all help!


#2

Maybe you are out of storage space. How big are the SD?
Have you expanded the filesystem with raspi-config?


#3

Thanks for that. The expanded filesystem was the thing that I needed to do! Great catch!


#4

I ran into this one, too. Maybe you should point it out on the start page!


#5

I guess that is easy enough to do, but there is not an enormous amount of space requirement due to Flotilla itself… this is really a basic step that has nothing to do with it and something that would bite you sooner rather than later. It is pointed out here:

… it only applies to non-NOOBS install, which themselves probably should come at this stage with a warning that running raspi-config and familiarising one-self with it is a good idea. As to why Raspbian initial boot no longer kicks you there right away I do not know.


#6

Yeah, of course this should be handled directly by raspberry. But a little hint by you would not harm anyone, right? ;)
I think the concept of flotilla is not to get too familiar with the underlying stuff, just get up and running as fast as possible. But this is your project, I don’t want to mess with your kind of doing things, of course.