No response from Dock



I purchased the large starter kit at the Raspberry Pi Big Birthday weekend and have so far had no luck getting anything to work.

I get the same symptoms as this post here: except I haven’t had it working previously.

I’m running a fresh install of Raspbian Jessie on a Raspberry Pi 3. I’ve installed using:

curl | bash

but when I launch Rockpool from the menu, click connect on the local ip, I don’t get any of the modules that are attached listed to select.

When I do the following:

sudo services flotillad stop
sudo /usr/bin/flotilla -d

I get:

[2016/03/07 19:10:59] Flotilla Ready To Set Sail...
[2016/03/07 19:10:59] Listening on port 9395

and then nothing else.

If I try and update the firmware to the latest version using:

sudo ./update_firmware

I get the following:

Any help would be gratefully received as me and my son are dying to try this out! :)




hum, interesting (in a not so positive sense), I assume by same symptoms in other thread you mean LEDs flashing in sequence?

… so the update_firmware script poses, then resumes when you plug the dock in, but fails to write the firmware, meaning when you plug it out then back in they keep flashing continuously (and not just for a few seconds)?


Ahh sorry, I didn’t notice those symptoms, just the “Listening on port 9395” and then nothing bit.

I’ve got Power and Hello lights solid and the Talking light is pulsing slowly.


the rockpool/flotilla daemon you are in effect using this way are not compatible with the latest firmware, the one found in the pre-repo. This could be the problem if you successfully flashed it trying to get things to work initially.

You need to either switch to the ‘shipshape’ level on all front, as per ‘pre’ (somewhat succinct) instructions, or re-flash the original firmware using the ‘upload’ script that you should find on your system under ~/Pimoroni/flotilla/flotilla-offline.


something that comes to mind as possible cause for a dock not stably registering a connection, as your failed attempt to flash firmware in the screenshot posted, is that it’s not getting enough power.

Make sure to use an official PSU (2A or 2.5A), and switch the max current on for the USB port. You can achieve the later using:

curl | bash


Hi, thank you so much for your help so far. It really is appreciated. :)

When I run the upload script, I get the following:

So as per the suggestion, I tried again with --force but it’s been stuck like this now for about 10 minutes. (I did run it with the usb cable unplugged, then plugged it in when instructed)

pi@raspberrypi:~/flotilla-offline/firmware $ sudo ./upload --force
Flotilla Firmware Uploader

This script will reflash the current dock firmware.
This may be needed if your dock stops responding.

./upload: 26: read: Illegal option -s

Plug in your Flotilla Dock now.
Updating should continue automatically.

<< That was supposed to be an image but it seems I’m not allowed to post more than one image! >>

The PSU I’m using isn’t an official one, but it is rated at 2A output. I attempted to run curl | bash but got a 404 back from that url.

Thanks again for your continued help.


Further to the max current, I’ve just had a google and my max_usb_current in config.txt is already set to 1. :/


oups, typo, the script I was trying to link is named ‘getstarted’, but if you have confirmed your setting is already at max then it won’t help.

It would seem that your dock is just not playing ball, or seem to exit out of bootloader mode prematurely. The last suggestion I can make is to use a micro-USB to USB cable as short as possible and substantial shielding, if you have anything of that description at hand.

… I do REALLY recommend you invest in one of the official PSU though, not all of them are created equal and I have had myself some unexpected results with other 2A rated power supplies and the Pi3, though admittedly I am pairing it with the touchscreen.


Ok, thanks.

I’m going to order an official PSU and in the meantime try it with a Pi 2 (and maybe the Pi Zero) while I wait.

Thanks again.



Realised I had an official 2A PSU knocking about with my Son’s Pi Zero kit, so have tried again with that.

Same results when I try flotilla -d, so attempted reflashing the dock again.

sudo ./upload:

and then sudo ./upload --force:

And now the dock’s three lights are flashing in sequence. :(

Oh, and I’ve tried this on my 3, a B+ and a Zero with identical results. I haven’t got a short micro-USB to USB cable as you described, I’m only using the one that came with the starter kit.

Any other ideas / things I can try?


I’m kind of surprised a dock could be DOA this way, they are resilient beasts, but I guess it’s possible.

While the cables that ship with the kit are on the long side I’m not sure they’d be the culprit here but I would shoot an email to requesting a replacement dock and ‘red’ cable (the later to be on the safe side). Reference this thread if asked what troubleshooting steps you’ve already been through (someone may have additional useful suggestions).


That said, the chip seems to respond but not persist as a connected device so I’m more inclined to think it’s a faulty cable. That would also explain why the dock went through QA without concerns. Either way, we got to get you up and running!


Yeah, I’m really surprised as everything else I’ve had from Pimoroni has been superb.

BTW, I don’t mind sending the dock to you chaps to have a look at, y’know, there’s always a chance I’m doing something really stupid. ;)

Thank you again for your time and your help.



I don’t know what the process is, there might be a RMA procedure for the dock.


@Pimoroni Team and fellow Flotilla Backers,

Hope to find some help here on the situation I face. [ I scrolled through all the threads in this forum and determined here is a good place to post my question ]

Some background: I am totally new to RPi. May need some hand holding here.

I own a Ares delta 3D printer which runs on Octoprint interface and RPi 2B+ and other electronics.
Have not actually printed anything yet.

Here’s how I set up the Flotilla, based on instructions in

Well, I actually used the RPi 2B+ inside the Ares 3D printer connected to my laptop, to install Rockpool.
Not the best of way? (according to my friend, “OS may have different flavour… Even the same rpi os, but it may have different libraries and different configuration…”)

There were 2 interruptions but as you see from the video [Ares 3D printer and Flotilla] (, finally managed to install Rockpool.

But unfortunately, (although I had managed to see “Flotilla” under the programming tab of RPi), however in the main screen of Rockpool (Flotilla’s software control interface), everything is frozen, clicking on the tabs, there is no response.

Hopefully someone can nail down the possible reason why everything is frozen.

Thank you, Ivan Hoe


Are you trying to run Rockpool on the Raspberry Pi? It’s much more stable if you run it on a separate Windows or Mac machine through the browser at It should automatically find your dock, or you can manually find it by entering the IP address of your Pi.


Thanks for your help. It does not work. I connected the dock to my pc and went to the browser at > after many minutes still " no docks found, yet! =( "

*With dock connected to pc, the LEDs labelled POWER, HELLO light up solid blue, while TALKING LED slowly fades a bit, then returns to normal, then the cycle repeats.

I am a noob.

How do I manually find the dock by entering the IP address of my Pi? As it is, right now, the dock is connected direct to my pc.

Appreciate your help. Tks


We only officially support the Raspberry Pi as a device to connect the dock to at this time. There is a tentative support for Windows PC but it is not ready for public comsumption.

That’s not to say it is impossible, but I wouldn’t call it straightforward unless you have some experience, particularly as your firmware probably needs updating, and that is (currently) immensely easier to perform from a Pi (or a linux or OSX box).

So, you should connect your dock to a Pi and follow the instructions on how to install the software, namely:

curl | bash

The installer will automatically update your firmware, as well as install the flotilla daemon, which, after a reboot, will make your dock available to control from anywhere on your network.

To locate it, you should point your browser, from your Windows PC or a tablet connected via WiFi to:

It should detect your dock automatically. If not, then try to find out what your Pi IP is with: ifconfig. It shouldn’t be necessary however.



I recently picked up the Flotilla Mega Treasure chest and am unable to get past the “searching for docs”, “no docs found yet!” screen. I am successfully connected to the internet and using the latest version of rasbian on a Raspberry Pi 3 B. The only thing that looks a little fishy is during the “curl | bash” script, I see a few Apt that fail to install, including libboost-system1.50.0, with an “unable to locate package” message. Libboost-program-options1.50.0, Libboost-program-filesystem and libboost-date-time with the same version numbers. I have also tried swapping the cables, but the blue lights look fine in all connection scenarios. How do I fix those libraries and what else do I need to do to get this to connect.?

Thank you!!


Might be worth grabbing flotilla-offline and running that installer to see what happens:

git clone
cd flotilla-offline

The latest version of Raspbian (Stretch) should be grabbing libboost-system1.58.0 and related packages.

Looks like the rockpool installer might not work in Stretch. I’ll have to fix that!