Dock not found


#1

I have a dock from the original Kickstarter campaign that was working perflectly the last time i used it (alebit over a year ago). I reinstalled everything from scratch including a clean install of Jessie and followed instructions to setup up the dock and rockpool.

Everything seems to work fine apart from the updating of the firmware - i am getting a message to say that the current firmware version is unreadable. The process to update seems to progress but then just stalls and i do not get any confirmation that the firmware has been updated.

The dock just sits there with three blue lights and the talking light gently pulsing.

Any help appreciated - novice pi user so be gentle!


#2

That’s odd! Could you walk me through the steps you take to update the Dock?

It should flash just one LED for a few seconds when it’s first plugged in- this is the bootloader stage, where it’s accepting new firmware update commands. If you miss that window, it may not update.


#3

Hi there, thanks for the response.

I downloaded raspbian Jessie and updated using apt-get update && apt-get upgrade.

Then used curl -sS get.pimoroni.com/flotilla | bash

The dock was plugged in at this point

I followed the instructions following the download and followed instructions until the point of firmware upgrade.

The dock is found but states that the firmware is unreadable and will be updated to firmware 1.14.

It then asks to make sure the dock is plugged in and press any key to update.

After pressing a key nothing happens.

The three lights on the dock are lit throughout with the talking light pulsing slowly.

Thanks


#4

Might be worth trying the following steps:

git clone https://github.com/pimoroni/flotilla-python
cd flotilla-python/firmware

Then type the blow command in, but don’t run it yet:

sudo ./raspi/dfu-programmer atxmega32a4u erase

Unplug and replug your dock, then run the above command.

Now the dock should be in bootloader mode until it’s updated, so next you need to type:

sudo ./raspi/dfu-programmer atxmega32a4u flash flotilla-dock.hex

Hopefully running these one by one will either work, or show us where the holdup is!


#5

Hi i have tried the steps described and got the following: the first command:

git clone https://github.com/pimoroni/flotilla-python
Cloning into ‘flotilla-python’…
remote: Counting objects: 724, done.
remote: Total 724 (delta 0), reused 0 (delta 0), pack-reused 724
Receiving objects: 100% (724/724), 590.60 KiB | 115.00 KiB/s, done.
Resolving deltas: 100% (417/417), done.
Checking connectivity… done.

After the next steps as described i get:

pi@raspberrypi:~ $ cd flotilla-python/firmware

pi@raspberrypi:~/flotilla-python/firmware $ sudo ./raspi/dfu-programmer atxmega32a4u erase
dfu-programmer: no device present.

Any thoughts welcome…


#6

Have you got another microUSB cable to try? It’s often a point of failure.


#7

Hello
I have the same problem, I was actually able to flash and the device is found during installation of Flotilla software. I am however unable to connect to the dock when I start the flotilla software. I have tried manually typing the IP of my computer, tried different cable and different USB port. The dock just sits there with all lights on, and the talking LED flashes slowly… Any suggestions?

  • when i run the install again, the dock is found, even with the new firmware and it gives me the option of reflashing…

#8

Are you using the Flotilla Software / Dock on different computers? It could be a firewall thing.

Also, do you know which browser you’re using?

It might be worth trying this version of Flotilla Rockpool: http://flotil.la/rockpool-edge/


#9

Hi
I’m using raspberry pi fresh install of NOOBS. The installer finds the dock during the Firmware check but Rockpool does not afterwards. The comand: “sudo ./raspi/dfu-programmer atxmega32a4u erase” also reports no device present. Ill try another computer/using rockpool-edge. and will report my findings.

Thanks!


#10

I suspect the Flotilla Daemon software is not running- it’s the piece of software which speaks Serial to the Dock and WebSockets to the Flotilla Rockpool front-end, without it the two have no way of communicating.

Try opening up terminal on your Pi and typing: flotillad to see what happens.

It may also help to run this: https://github.com/pimoroni/flotilla-offline

git clone https://github.com/pimoroni/flotilla-offline
cd flotilla-offline
sudo ./install

#11

Installing flotilla-offline did the trick. Thanks for your help!


#12

I get Unsupported version of Raspbian! if I enter sudo ./install.
Using newest Rasperian with Debian Stretch.

The “normal” install instructions do not work either under this OS.
I get several messages like this:

libboost-system1.50.0 is required
Installing libboost-system1.50.0...
E: Paket libboost-system1.50.0 kann nicht gefunden werden.

I think I need version 1.58 of this libboost packages, which I installed manually by doing:

sudo apt install libboost-system1.58 libboost-filesystem1.58 libboost-program-options1.58

But this did not fix the problem.

I also tried to do sudo cp flotilla-offline/flotilla-stretch /usr/bin/flotilla afterwards, but this doesn’t helped.

If I enter flotilla on the command line, I get the error Unable to open pid file

I’m really frustrated after spending over hundred bugs for this “beginners” kit, which I never used until now…

If I check running services by doing ps -aux | grep flotilla I get this result:

root       403  1.5  0.2  32324  1960 ?        Sl   08:55   0:01 /usr/bin/flotilla --pid-file=/var/run/flotillad.pid --log-file=/var/log/flotillad.log

so it seem the flotilla process is running.
This is what I get after entering tail /var/log/flotillad.log:

[2018/05/15 08:59:55] Connection Opened
[2018/05/15 08:59:55] Client Saying Hello!
[2018/05/15 08:59:55] Sending Ident: # Dock: 1.14,1b000f0035573132313504,Unnamed,Unnamed,0
[2018/05/15 08:59:55] Connection Closed
[2018/05/15 09:00:02] Connection Opened
[2018/05/15 09:00:02] Client Saying Hello!
[2018/05/15 09:00:02] Sending Ident: # Dock: 1.14,1b000f0035573132313504,Unnamed,Unnamed,0
[2018/05/15 09:00:02] Connection Closed
[2018/05/15 09:00:08] Connection Opened
[2018/05/15 09:00:08] Client Saying Hello!
[2018/05/15 09:00:08] Sending Ident: # Dock: 1.14,1b000f0035573132313504,Unnamed,Unnamed,0
[2018/05/15 09:00:08] Connection Closed
[2018/05/15 09:00:14] Connection Opened
[2018/05/15 09:00:14] Client Saying Hello!
[2018/05/15 09:00:14] Sending Ident: # Dock: 1.14,1b000f0035573132313504,Unnamed,Unnamed,0
[2018/05/15 09:00:14] Connection Closed
[2018/05/15 09:00:20] Connection Opened
[2018/05/15 09:00:20] Client Saying Hello!
[2018/05/15 09:00:20] Sending Ident: # Dock: 1.14,1b000f0035573132313504,Unnamed,Unnamed,0
[2018/05/15 09:00:20] Connection Closed

Thats all

[EDIT]
I could fix my problem by adding Version “9.4” to the install script.
Started a pull request at github: https://github.com/pimoroni/flotilla-offline/pull/18