Unable to interract with the Dock


#1

I’m using a Raspberry Pi 2B with the latest OS. Some times when using Rockpool the dock is not found, sometimes it is. When it is it is unnamed (because I have not done it yet) how do I do that? Also under the dock it says “this dock needs an update”. There is also an exclamation mark in a red disk at the bottom of the dock. Wherever I click I get a very useful screen on how to do great things with Pimoroni kit, but nothing about Flotilla. Where do I start. I have searched for answers with no luck.


#2

have you ran the following recently:

curl https://get.pimoroni.com/rockpool | bash

… the online portal is no longer compatible with the original firmware, nor daemon available then.

Renaming can only be done via serial at this point, but we’ll have a more friendly way to rename the docks in the near future.


#3

Hi RogueM, thanks for your reply, no I have only used “curl get.pimoroni.com/rockpool | bash”. Will try and get back to you.


#4

it should do the same thing, but it depends when you’ve done it. At this point, it should take you to a routine that checks the firmware version and offers to upgrade it if necessary. If it is the latest it will also offer to refresh it (which may be useful if all else fails).


#5

I get the same error, need to update the firmware.

I have just ran curl -sS … to up adept the firmware and get an error message line 697 cd: /home/pi/Pimoroni/flotilla/source/firmware no such file or directory.

I also added sudo in front of the command, same problem.
Under Pimoroni/flotilla there are two folders flotilla-offline and flotilla-rockpool .

No source file folder.

I am running on a B3, Jessie , ephinany browser, I have ran sudo apt-get update etc.

Confused

Steve


#6

Many thanks RogueM, It seems to be working, I don’t know how, I did what you suggested with no luck and then re-installed flotilla and we are go!


#7

let me check the script, looks like a gremlin popped its ugly head at some point recently!


#8

Booted the Pi today and back to square 1 1/2, dock not connected, but on the page which has inputs top left outputs top right.


#9

I’m with you. Nothing is working for me at all.


#10

It gets weirder and weirder. By just fiddling I have managed to get the slider working with the matrix, but if I then open another tab and try to run a cookbook recipe, the page loads but is instantly overlaid by the searching for dock panel. Though the dock is there, and working in the other tab, it cannot be found.


#11

Try to run:

curl https://get.pimoroni.com/flotilla | bash

… make sure the firmware is detected as version 1.14, otherwise reflash it.


#12

Thanks RogueM, tried that, can’t connect at all now.


#13

Did the process confirm that the firmware was at version 1.14? If so your dock might be spitting out data that confuses rockpool… try the following:

sudo service flotillad stop
/usr/bin/flotilla -d

in particular inspect the user and dock names, you may see some ASCII extended characters after ‘Unnamed’.


#14

Thanks RogueM, tried that. Everything seems OK as the dock and i/p and o/p I’ve connected are noted, but the last line says Segmentation fault.


#15

Hi RogueM, thought you might like to know, I have been on the Getting Started / Cookbook page after re-installing flotilla and it works. Looking forward to exploring.