Can't find previously working dock or get it working [SOLVED]


#1

I used my dock with Rockpool successfully last week, was away for the weekend and now when I try it it can’t connect. All three lights power hello and talking flash in sequence continually.
lsusb sees device ID 03eb:2fe4 Atmel Corp. ATxmega32A4U DFU bootloader.
If I stop flotillad from running and then try
/usr/bin/flotilla -d
I get
Flotilla Ready To Set Sail…
Listening on port 9395

but nothing further
Uisng the correct red usb lead to connect to the dock.
Running Jessie on a Pi2.

If I try running the menu flotilla command and connecting to 127.0.0.1 the interface comes up on teh web browser but it doesn’t seen any modules, even if they are plugged in. eg if rainbow plugged in nothing shows under output.

What do I try next?


No response from Dock
#2

The LEDs on the dock should stop flashing after a few seconds. If, not, I’m not sure what could be up - is your PSU the same as last week?


#3

Yes same setup. Tried on two Pi2 with different power supplies with same results.


#4

You could try reflashing the firmware, though I’m not sure why it would be corrupt. That said I am pretty sure it happened to me once.

To do that, head over to https://github.com/pimoroni/flotilla-pre/

and clone or download a zip of the repo. In the ‘raspi’ folder you will find the dock firmware. Make sure to use the ‘revert’ script in order to use the current version of rockpool and Python API.


#5

Thanks. re-flashing the firmware did the job. No idea how it became corrupted in the first place.
Having had to do this and seeing how easy and quick it is, I’ll perhaps have a go at upgrading the firmware and trying out the mac software as well now.


#6

Yes, indeed, it’s a straightforward process to revert the firmware if shipshape does not work for you, but at this stage it’s pretty solid in my view.

Note that you can also use http://flotil.la/shipshape to connect a client to the machine Flotilla is running on, i.e access the dock hooked up to a Pi from your Mac. Not that I expect the Mac version to cause you trouble (if you are running Mac OS X 10.9 or above) mind you.


#7

This is curious. I’ve got a support ticket with a very similar problem. One to keep an eye on to see if there’s any common factor at play here!

I don’t see any reason why the firmware would corrupt, but it’s a complicated beast!


#8

Just to say that the same thing happened to me again tonight. I rebooted my Pi2 with the hub connected and when it restarted the firmware was scrambled again and it wouldn’t link. I reinstalled it and it was OK again. This was all with the latest firmware installed.


#9

Thanks. This is useful! I’m making some cursory attempts to replicate it, with no success yet. Actually I haven’t seen this problem at all in many months of tinkering with the dock. It could be something related to your dock, or your setup. We’ll see how it goes!