Raspberry Pi (1) won't boot after installing Flotilla


#1

Hi, I tried today to have a tinker with the Flotilla modules for the first time.

I have a Raspberry Pi 1 (I know the ‘Setting up the Dock’ instructions that are inside the box say that it works best with Raspberry Pi 2 but, hey, when the Kickstarter campaign was around about a year and a half ago it was normal to have a RPi1). I installed Jessie OK, but then after installing Rockpool and rebooting, the Pi never booted up again. Now, I’ll have to re-install Jessie and try again (I even deleted the installation files from my computer because my hard disk was getting full so I’ll have to download it all again. sigh). It scrolls through the initial checks you get on startup, but then just stops … never goes to desktop, and I can’t see if there’s any errors …

Is it ever going to work or am I wasting my time?? Any suggestions? Help much appreciated :-)


#2

did you expand the filesystem on the SD?

to do so, as well as setting up some useful and recommended settings for flotilla run:

curl -sS get.pimoroni.com/getstarted | bash

… then proceed to install rockpool after reboot


#3

Thanks for your reply.
To clarify, after installing Jessie I should run the 'curl … ’ command in the Terminal of the RPi before installing rockpool?


#4

Also, do you know how much space is needed to install rockpool?
I tried from scratch a second time and when I tried to clone the source-code it said there wasn’t enough space on the disk.

Since I’m a Raspberry Pi novice I’m a bit confused because I’m using an 8GB SD card but after the rockpool installation failed, I shut down the Pi and took out the SD card and put it in my Mac and when I did a ‘Get Info’ on the disk it said capacity is only 62.9MB (Available 44.2MB). When installing Jessie, does it somehow bring down the capacity of the card??


#5

After wiping the disk clean again and observing the 8GB capacity and then installing Jessie for a 3rd time, and looking at the capacity again, I conclude that it does indeed affect the capacity on the card. I’m learning as I go. I’ll await your response before trying to install rockpool again …


#6

OK, read here that the available space that the computer says is not as it seems:
https://www.raspberrypi.org/forums/viewtopic.php?f=91&t=111081
Still doesn’t explain why I couldn’t install Rockpool due to lack of space :-(
I’ll check later how much space is actually on the Pi.


#7

yes, please run the command I posted before installing rockpool, or for that matter anything. Until the filesystem is expanded there will be very little room, and you will run into trouble pretty much right away - this has nothing to do with Rockpool per se, but the way imaging Jessie works.

Alternatively run:

curl -sS get.pimoroni.com/rockpool | bash

which should also prompt you to expand the filesystem to use up the entire SD capacity if there is not enough space for the estimated requirements.


#8

Great thanks so much for your help. I’m up and running. Also found your guide that uses touch and rainbow modules to turn different coloured LEDs on/off. Nice (although the third channel on the touch module does not respond).


#9

I see this question pop up a lot- that is, the one of “why does the card say it’s ~63mb and not 8GB when I put it in my computer?”. I think it’s easy for us to forget that the simplest of concepts can be impossible to understand until they’re explained. So I’ll just try to fill in that explanation.

The 63mb you see is the Windows-readable “/boot” part of Raspbian. This 63mb is a slice of the total SD card capacity called a “partition.” Partitions almost act like separate drives, and they can be created in a whole variety of different formats, which are just slightly different ways of storing bits and bytes that different operating systems may or may not understand.

Windows uses a few common formats: FAT, FAT32, VFAT, exFAT and NTFS.

Linux understands these, but tends to store its files in one of the EXT formats: ext2, ext3, ext4.

So when Windows comes along and looks at your SD card, what it really sees are two or three separate drives. One of them it can understand, but the others … well it knows a drive is there, but it has no idea how to read it.

So the reason you see only a small sized disk is that the majority of space is used up by a big Linux ext4 partition that Windows has absolutely no idea how to read.

If you fire up Windows “Partition Manager” you can actually see the slices of disk and what they are.

Noooow… here’s where it gets a little more complicated. A disk partition doesn’t have to fill all of the disk, or even any fixed quantity of the disk. And when distributing disk images like Raspbian Jessie it’s sometimes important to be conservative about how big your partition is. Too big, and subtle differences in the size of an SD card might trip you up. 8GB SD cards might be a few bytes bigger or smaller across brands and if you’ve put something important in those bytes ( filesystems aren’t particularly ordered about how they use the space given to them, often intentionally ) then… boom!

So Raspbian Jessie’s main partition is crunched right down to the point where there’s only a few megabytes worth of free space allocated to that partition. When you flash the image to the SD card, this same scheme is copied verbatim and the rest of the SD card is left as empty, unallocated disk. Here be dragons and all that! Linux ( or anything writing to a filesystem ) can use the space that’s allocated, but it hasn’t been given permission to use the empty parts of the disk, even if they are empty!

SO one of the first things we do on Jessie is to “grow” the partition. That is we allocate that empty space to it and say: “Hey, you can use all this space too now!”

And suddenly Jessie goes from having 20mb of space, to having a couple of gigabytes.