Raspberry Pi 2 - boot failure (ACT & PWR are steady green and red)


#1

Hi,

I just received my Raspberry Pi 2 from Pimoroni last Friday, but I can’t really boot it (no booting screen at all).

USB power supply: 5V 2A
Lexar 633x Class 10 micro-SDXC 64GB
OS: Ubuntu MATE 15.04
Official Raspberry Pi WiFi dongle

What I’ve tried:

  • WiFi dongle or network cable
  • different 5V 2A power supply
  • different USB cables
  • different monitor / TV
  • different HDMI cables
  • with micro sdcard or without

But ACT & PWR leds are always steady green & red when power cable is attached. None of it flashes during booting. And TV / monitor just says no signal.

Thanks a lot for your help.

Sorry, since I’m a new user, I’m not allowed to post any picture, but the leds are just as mentioned above, steady green and red.


#2

Have you tried it using another SD card with Raspbian installed? I’m pretty certain your Pi is fine and that either:

  1. The Pi doesn’t like your SD card, which shouldn’t be the case as many 64GB SDXC cards have apparently tested fine
  2. Ubuntu MATE isn’t properly installed on the SD card

What’s the procedure you followed to get Ubuntu onto your SD card? Which operating system do you use on your desktop computer?

I’ve not used Ubuntu MATE yet, and haven’t tried anything bigger than an old 16GB SD card, so you have me at a disadvantage, but I’ll guide you through the usual debugging steps.


#3

I wouldn’t recommend using a 64GB SD… while some users have had success it’s clear it isn’t true for many, and I suspect you are one of them. Just my 2 cents.


#4

Thanks guys for your replies.

Yes, so all of you think the problem might be the super large and fast SDXC. I have the same feeling.

While actually according to here: http://elinux.org/RPi_SD_cards
It’s saying my Lexar SDXC 64GB Class10 is OK. But I mean, it’s not official, and may depends on luckiness.

So I just borrow an normal microSD from a friend of mine, trying now. Will let you know if it works or now.

Thanks again.


#5

Finally, made it work.

It turns out that one step was missing from the official documentation of image installation on Mac OS.

The missing step is to zero out the partition map by:
sudo dd if=/dev/zero of=/dev/r[disk_name] bs=1024 count=1

I followed the complete guidance here:
http://wiki.openelec.tv/index.php/HOW-TO:Installing_OpenELEC/Writing_The_Disk_Image#tab=Mac_OSX

Thanks for everybody’s help. And hope this thread will be useful for anyone has problem installing image on Mac OS.


#6

BTW, my 64GB 633x SDXC card works great.


#7

Alright!

You don’t need it anymore, except if you want to clone your card for backup purposes (another reason for me to prefer small capacity SD), but I can highly recommend this *nix GUI frontend to dd:

https://www.thefanclub.co.za/how-to/dd-utility-write-and-backup-operating-system-img-and-iso-files-memory-card-or-disk

… saved my ass a few tines already!


#8

I envy your capacious SD card- the biggest I’m running is 16GB in a Pi I basically never put anything on! And I’m glad you got it up and running!