Raspberry Pi2 won't boot


#1

Hi,

I have a Pi 2. When I power it up the green light flicks on for a second, then goes off. The red light comes on and stays on, and that’s it.

There is no HDMI output.

A different Pi with the same peripherals (different card) works fine.

Any ideas? Is it DOA?

Regards

Darren.


#2

Does a different Pi with the same SD card work fine? It’s much, much more likely to be the OS on the SD card than the Pi itself. I’d peg the odds at a million to one if I were a betting man!

Anyway, you should be able to sort the SD card out yourself by grabbing and installing either the latest NOOBS image, or Raspbian image from the Raspberry Pi website here: http://www.raspberrypi.org/downloads/

Have a look at both the NOOBS setup guide: http://www.raspberrypi.org/help/noobs-setup/

And the image installation guide: http://www.raspberrypi.org/documentation/installation/installing-images/README.md

For clear instructions on how to do this.


#3

Hi,

Thanks for the post. I’ve just tried:

Pi 2 with known-good SD card from Pi B+ -> won’t boot, just displays a coloured screen?
Pi B+ with card from the Pi 2 -> boots fine

I’ll try the Pi 2 with a new SD card and a different image to see if that makes any difference, but it’s looking like the Pi 2 is DOA, sadly.

Thanks again for your help.

Regards

Darren.


#4

Hmmm… putting the default Raspbian on a new SD card worked fine, and the Pi 2 is now booting.

The first card I used was a Sandisk Ultra 32Gb card, while the one that worked was a no-brand 8Gb card.

Anyone know of any issues with the Pi 2 and Sandisk cards?

Regards

Darren.


#5

Damn, the Pi 2 is fast!


#6

You need to update B+ cards before putting them in the Pi 2, otherwise they simply wont boot- they need the newer kernel release. You can do that by running:

sudo apt-get update
sudo apt-get upgrade

As for the Sandisk Ultra 32GB, I don’t know about any issues. Where did you get the image from for the Sandisk card? It could be that it’s just not updated?


#7

Hi,

I was using a Retropie image. I’d read on a blog that it worked with the Pi 2 but clearly that is not correct.

I’m going to try the standard Raspbian on the Sandisk card and see what happens.

Thanks

Darren.


#8

I have the same issue, B+ SD with update/upgrade, works on B+ but on P2 it does the one flash of green then stalls,

A new NOOBS SD installed on the P2 works, it boots… And runs… And putting that card into the B+ works fine.

I wonder if there is a boot block on the B+ installed card which needs changing…

Ideas please.


#9

There’s no boot “block”, but it’s possible that the contents of /boot didn’t update properly. Pop the card in your B+ and:

ls /boot/

A Pi 2 compatible card should have a kernel7.img in that folder.

Also, where did the not-working-in-Pi-2 SD card come from?


#10

Hi,

The Sandisk SD cards work fine, it was the image that was the problem.

The latest Raspbian image on Sandisk worked perfectly.

Regards

Darren.