New Pi 3 doesn't boot


#1

Hi, I have just received my new Raspberry Pi 3 from you. I put in a new Class 10 16GB NOOBS card and powered up with HDMI monitor and keyboard connected but unfortunatly it doesn’t boot. It just displays the Red/Green/Blue colour screen and the green LED on the board flashes, 4 slow flashes followed by 4 fast flashes and then round and round this cycle - I guess this means something?
I have tried the NOOBS card in a Raspberry Pi 2 and it boots up without a problem.
I have tried the working card from that Pi2 in this Pi3 and it fails to boot with the same flashing green LED.

I would say this points the finger at the Raspberry Pi3 as being the faulty item but do you know what the LED flashing actually means?

Is it something I can fix or should I return the Pi3 to you for exchange?

regards
PhilipJ


#2

You absolutely, definitely, need a less-than-a-week fresh Jessie or NOOBS card to boot a Pi3. If you did not order the card from us at the same time as the Pi then it almost certainly is not compatible.

If so, go to http://raspberrypi.org/downloads/ and grab a fresh copy of either NOOBS or Jessie and reimage to the SD card.


#3

Thanks for the really speedy reply :-)
I looked everywhere to see if there were recommendations about what I needed and I didn’t find anything, hence my mistake.
To be honest I forgot to order a card with the Pi3 and getting one from Amazon (next day delivery) was the quickest option - not so quick as it turned out.
I will re-flash the card as you suggest

Thanks again
PhilipJ


#4

np. I know what you mean, I’ve spent a few hours this weekend looking in my box of not-so-well labeled SD cards for something I could use in my Pi3 myself.

I recommend running the following once you got it to boot and got to the desktop (from a terminal window):

curl -sS get.pimoroni.com/getstarted | bash

… it’s a work in progress but will do a few useful things that are commonly required or at least desirable to perform on an initial install.


#5

Hi,

did as you suggested and now it boots perfectly - thanks for the help

regards
PhilipJ


#6