Raspberry Pi4 not booting

Hi, I received by Raspberry Pi 4 a few days ago but I have had no luck with getting it to boot. I am using the official power supply and have many older Pi’s working perfectly (So I have some idea what I am doing).

With nothing plugged in I get the red power LED on, and the green LED flashing in a pattern (3 short flashes, a long flash then repeats). With an SD card plugged in (Either a working SD card form my Pi3 or a newly flashed one) the green LED illuminates briefly, then nothing. No more green LED. The red is on at all times.

With an ethernet cable plugged in I get not activity on those LEDs either, and the HDMI out put (both of them) has no signal on my Samsung TV.

I even tried the recovery file they have on the website to restore the EEPROM but no luck.

Does anyone have any ideas what the issues could be? Have I just been unlucky and received a dud?

You are using a very fresh download (less than 2 weeks old) of RaspBian “Duster” or Noobs?
Anything older will not work.

Yes I downloaded a new copy on Saturday just for the Pi4. I also made sure to update the card from the Pi3 to the latest before trying that SD card. Neither are doing anything. I’d expect to see some output or something on the screen if it was trying and failing to boot.

Sounds like you tried both HDMI, anyway HDMI (0) is the one I would recommend using on boot up. And maybe try a different TV / Monitor.
Is the Pi in a case? HDMI adapter or just a cable all by itself?

I have taken the case off to try without and both HDMI 0 and 1. I don’t have another screen to try, but the absolute lack of activity lights makes me think that’s not the problem. It also doesn’t receive an IP despite being plugged into Ethernet (I checked on the router)

Yeah, if the activity light isn’t flashing its not booting.
Did you do a dist-upgrade on the Pi 3? I ask because I’m not sure if the regular update upgrade will switch it from stretch to Buster? And only Buster will boot on a Pi 4.

Found this, https://www.raspberrypi.org/forums/viewtopic.php?p=1484438
Looks like they recommend using a fresh image.

I did dist-upgrade on the Pi 3 SD card yes (I was hoping to migrate it rather than set everything up again) but I also tried a fresh SD card that has the latest Buster image on it. Neither had any luck (0 activity or output)

I’d try a different Micro SD card and redownload Buster. Not much else you can do.
If it still won’t boot you could try posting on the Pi foundation forum.
There is also the option of going to the main Pimoroni Shop page and doing the contact us. Link is at the bottom of the page. That should get you a quick response from somebody at Pimoroni.

1 Like

It was indeed an issues with the SD card. I created a new one and it worked. And updating the Pi 3 one properly (I forgot to change the source files) works too. Thanks for the help!

Thats good to hear, now you can have some fun. =)