Raspberry Pi 4 Wont Boot Up or Display

I recently got the Raspberry Pi 4 (4gb). I downloaded the OS to load onto a 128gb micro SD card and continued with set up. Both on my TV via HDMI and computer monitor nothing comes up. I have read on several forms to see what could be wrong with it but I have had no luck being able to figure out what is wrong.

I have tried the Noob, and raspbain, both with and without recommended software. I have changed HDMI cords. I have tried booting up in every steps, and combinations.

When booting up, the red LED comes on solid but the green light does not come on at all.

I am pretty sure I have found and read every forum and watched every video on Youtube. I have gone through every set up instruction I can find. but alas nothing works.

The only thing I haven’t tried yet is the force HDMI, and it’s because every time I have found that to be an instruction, I cannot figure out how to change that setting.

The force HDMI edit is done to the config.txt file. That file acts like your computer BIOS settings does. If you put that Micro SD card in a reader and plug it into a Windows PC. The config.txt file is on the fat 32 boot partition and can be edited with a text editor.
Ignore the “must be formatted” prompt you get on a Windows PC. Close it via the X in the corner. It comes up because Windows can’t read the other Linux partition on the drive.
I would try a different smaller Micro HD card, just in case you got a fake card, of it has issues. Also make sure to use the HDMI 0 port not the HDMI 1 port. The one closest to the USB C power jack. I wouldn’t bother with NOOBS, just get the latest Buster. Only Buster will boot on a Pi 4B.

Lack of green light indicates the card is not reading (maybe corrupt) Noobs is simply installer software, Buster is included within Noobs for Rpi4. Works fine via Noobs for me. I have in the past ( with pi 3) had to “thicken” the depth of an SD with acetate in order to force connection between SD and card slot. Also I have, before now, missed the SD slot and put the SD between the slot and case? Resulting in similar symptoms.

I only ever run Raspbian so I don’t see the point in using NOOBS. Thats just me though. Imaging the card with straight up Raspbian isn’t all that much harder, IMHO. Different strokes for different folks.

I love Noobs , try flashing a Noobs image , you loose very little space and gain many more options easily and can easily chop and change distros as and when. it’s not just for newbies. Much easier to duel/ multiple boot with a Noobs card no need to swap sd’s

Just a thought but when installing from a Noobs card, you are choosing option for pi4 using a wired connection from the pi? It won’t populate and You won’t get the options without. After you flash Noobs you then need to put the card into the pi coñnect the pi to your router then install the distro (s) you need. Sorry if I’m stating the obvious

I use to wonder why noobs too, then one day i read a reason for it ,so new users would not have to learn SDFormatter and Win32diskimager tools , i did use it a bit one time to duelboot a couple of different OS’s ,but as you know me ,i have enough problems with 1 OS ,lol

thanks for all the responses everyone. I managed to get everything working. I had the Pi in a case that has a built in fan. I thought I would take it out and possibly return the whole set up. i disconnected the fan before shutting off power and then got a phone call. when I got off the phone I thought I would try messing with it some more and plugged the fan back in. to my surprise the screen lit up and it booted. The best I can figure is that I didn’t have enough power to boot with HDMI with the fan running at first. since, I haven’t had a problem. the cord is the recommended power output and came with the Pi but it just wasn’t enough I guess. I plan on getting a higher power output for it since I will be building a new case and will have more cooling fans. I think ill be going with a full external power supply so I don’t run into any more trouble later on.

My Pi 4B 4gig model ran just fine with the older Official Micro USB 2.5A supply. With an adapter of course. No fan just heatsink.
Latter on I got the official 3A Pi 4 USB C version and attached a Fan Shim. Still no issues. Just a FYI post. I also had a BLINKT attached showing CPU load. No undervolt warnings.
I’m not sure what went wrong with your setup but glad to hear you got it working. =)

Doesn’t NOOBS come with a full version of Raspbian that you can install without a network connection? I seem to remeber thats how it was when I used it many moons ago.
And an Internet connection was needed for anything else in the list, as it had to download and then install those optional OS’s. Something like that?

yeah,i think thats how it works,been awhile for me too since i tried it .

From the NOOBS download section:

NOOBS is an easy operating system installer which contains Raspbian and
LibreELEC. It also provides a selection of alternative operating systems which
are then downloaded frorn the internet and installed.

It does, which is fine if you don’t want to look at the other distros , or if you’re writing the latest version on to SD yourself. Buying preloaded Noobs cards cheaply, on eBay etc, you’re almost guaranteed to get outdated versions, then you have to update anyway, if they’ll boot at all. To avoid all the fakes I pretty much only use blank Evo+ cards from “reputable outlets.” ( And I even check those). unless sealed official packaged Noobs cards are at giveaway prices as it’s faster than copying new images. I’m continually updating friends LE Pi’s and I prefer to do a completely fresh install, overwriting using a different Os then rewriting. in fact now I just exchange cards and rewrite and or copy the old cards ready for the next one.