New RPi 4 not booting

Pimoroni Raspberry Pi Essentials kit inc Rasberry Pi 4, 4GB & Pi 4 USB power supply

Elecrow 7” HDMI LCD Screen

Pimoroni fan shim

High speed micro sd cards x3


I’m having a problem with my PI 4 …

All assembled, however when powering on, only the red led illuminates. There is nothing from the green led

I have tried …

Reseating the SD card

Re-imaging Raspberry Pi 32-bit with the Raspberry Pi imager

Disassembling everything and only using the Pi board connected to power and HDMI screen

Running for about an hour with no change

Am I doing something wrong?


Your steps to find the error are exactly what you should do, so nothing wrong on your side. Next I would try to use a different SD-card and if this does not help a different power-supply. Note that for a bare Pi4 you don’t need a 3A rated “Pi4”-supply, anything you have with 2A will do (as long as it has a usb-c plug).

Unplug any USB devices and try again. My Pi 4B would not boot up if my Wireless Keyboard dongle was plugged in.
Also, if you remove the SD Card and boot up you will get a diagnostics screen, that may clue you in to what’s going on?

Thanks for all the advice So, i have also tried …

RPi 4 bare with only red led illuminating with both Pi power supply and another usb supply

Connected a monitor and only seeing ‘no signal’