Raspberry Pi 4 Randomly stopped booting

Hello, i got my RPi4 4GB last July together with the offical power supply. It worked without a Problem from the beginning. The problem is after i left it powered off for some months i tryed to boot it up but it wont boot anymore.
things i tried:

  1. I tryed 3 different SD cards that worked fine on my RPi0w with the newest Raspian.
  2. Without SD card the RPi’s green LED blinks 4 times, with means the bootloader should be fine
  3. While booting the Green LED blinks 4 times, then stays on and repeats with 4 blinks etc. on the forum i read that means it cant find the start*.elf, but why should it suddenly be unable to finde that file.

The Pi was always powerd via the offical power supply and was savely tucked away in a case and even had heatsinks and a fan(The RPi4 would get way to hot for my tased otherwise).

So what else could i try? Any ideas?

There is this official Pi forum sticky on boot problems.

It sounds like its not reading the SD Card? I have had that happen to me, my SD Card failed. All I got was the four green flashes over and over.

I looked at that Post too, but i wonder why it should suddenly stop i didnt change anything and tryed 3 working SD cards, its like it suddenly cant read ANY SD card anymore.

That I don’t know. Did you image your cards with the new Pi foundation utility?
And are you using Raspbian or maybe NOOBS

I tried the Imager tool from the Raspberry Pi website to flash my image and i also used the Win32DiskImager i normaly use. I Downloaded and tryed the newest Desktop w/o recomended software Raspian and also tried the newest Raspian Lite. Never used NOOBS bevor so nope havent tryed that. but i also tryed a Lakka image and a beta Retropie image for the RPi4

Ok, it sounds like a hardware issue to me? It’s not reading the SD card for what ever reason?
You could try the eprom recovery. I don’t think thats the issue but it won’t hurt to try it.

Will try tomorrow, but i wonder if this will work if its realy a physical problem with reading SD cards.

If the SD card slot has a hardware issue, no it won’t work. Can’t hurt to try though, it won’t make things any worse. Its what i would try if i were in your predicament.

Tryed the flashing of the EPROM, the LED repeated 2 long 4 short i waited about a minute couldnt find the meaning of that code but it was a different while flashing so it did read something. But after inserting a Raspian SD-card its still showing 4 blinks and nothing else.

4 blinks is start.elf not found. What size SD cards are you using? Size shouldn’t matter if using the official imaging utility or win32 diskimager but I’ll ask anyway. I don’t know why your having this issue?

I don’t think that was a normal flash of the eprom? If memory serves me it just flashes continuously and very fast.

i tryed a 2GB with Raspian Lite 2020-2-13, and a 4GB, a 16GB, and a 32GB with Desktop Raspian

Yeah thought so, but i couldnt find what the code was indicating. i tryed the flashing with a 2GB FAT formatted SD card. the name of the Volume shouldnt matter, right?

How did you create your recovery SD card. It looks like your supposed to download the zip file and then image that to the card with the imaging utility?
That’s not how I updated mine, there wasn’t an official imager then.I believe I just created a fat formated card to do it. It was while ago and I only ever did it once to update to a test eprom.

I formatted a 2GB SD-card FAT and copied all the files inside the zip archive onto the sd card, just like the readme inside the zip archive told me to.

Ok, that sounds like how I did it. I’m out of ideas.

Okay, thanks anyway.

In order to get your Pi to boot successfully, you need a correctly written SD card. Meaning (when you use NOOBS) that you have to drag the contents of the unzipped NOOBS folder into the root of the card, NOT those files inside a NOOBS_v1_5_0 folder on the card, as it won’t boot that way, which is the main mistake people make. This will be covered in detail later in the post. If you are having trouble writing your SD card, please be sure to check out our NOOBS Set-up page.

I Guess you didnt read the whole thread because that was also asked by alphanumeric. That was definetly not the problem since i even switched the SD-card to other Raspberrys that would boot. The RPi seems to have a geniuen hardware defect. I have refundet my Rpi so i can’t look deeper into it but the SD-card slot had continuity on all pins and the SD-card could be identified (Different blinking pattern based on contend of the card) my guess is that either RAM or CPU had a problem but could also be a problem with the capacitor C8 for 1v1_DDR(Power for Ram, meaning if RAM failed to power the start.elf could be seen but not stored in RAM for use) found that some ppl had problems with that capacitor overheating, dont know if that was common but it would fit the symtoms. but as i said since i still had warranty i didnt look deeper into it.