Raspberry Pi4 wouldn’t boot Red LED blinks

Recently I got raspberry pi4 and it wouldn’t boot. I get only red led blinking. I have tried different power supply, fresh copy of OS and it’s doing nothing 😩😩😩😩

Are you using the official PSU, and if not which one(s) have you tried? Also, what SD card are you using (and have you tried a different one)?

Is it a steady blink? Can’t quite remember what the different lights mean these days…!

Hi. I have tried the official power supply, I also tried 2 different memory cards. From what I researched red blinking means that there is power supply problem, since I have tried 2 different ones I don’t know what to do anymore.

What extra’s if any do you have connected?
Anything connected to the GPIO header?
For testing you should have just keyboard mouse and monitor connected.
Did you use the official imaging utility to flash your SD card?
Latest official image obtained from a reliable source?
Monitor plugged into HDMI 1, the one next to the USB C jack?