Raspberry Pi 4 wont boot or illuminate any LEDs

So I received my Pi 4 yesterday and opened it today.

I firstly noticed it didnt come in an anti-static bag and was bare in the slightly crushed box. I’ve plugged it in today and nothing happens, no booting, no LEDs, absolutely nothing.

Any suggestons would be welcomed.


Are you running Raspbian Buster? Anything earlier will not boot on a Pi 4B.

What power supply are you using? Mine didn’t work with a MacBook USB-C adapter and cable. It had the same symptoms as yours with no lights after plugging it in.

Would you expect it to still display a red LED on the board though?

That’s one of the power supplies i’ve tried. I’ve also tried an Anker PowerPort which says it’ll do 5V at 3A. Have you got your working?

I think so yes, I don’t have my 4B yet but a 3B would have a power led lit even with no SD card inserted.

I had an official RPi4 PSU arriving the day after which worked ok, so I’m fairly sure the Pi is ok.

I also ordered the following Anker adapter and cable which arrived today. I’ve just tested that now and can confirm it also works:

So does my 3B. I’ve just tried it with an iPad Pro adapter (5V - 3A) and no joy either.

I’ve just tried it with an iPad Pro adapter (5V - 3A) and no joy either.

I think the issue is with the Apple USB-C PSUs because I had the same problem as you, but the Pi then worked fine on those other adapters.

It wouldn’t surprise me if the Apple Power supplies only worked when an Apple product is detected.

Interesting article:

At the end of that article it suggested the usb-c cable may be the issue, so I tried the Anker cable listed above with my 87W Apple Power Adapter, and it worked!!! The RPi4 successfully powers up with this combination of cable and PSU. :)

Thanks for the article and the other reply. It’s an interesting read.

If the article is correct, it looks like any cable that is capable of more than 5V - 3A will have the chip in it and therefore won’t work.

Would you mind trying something for me please. If you remove your MicroSD and just leave the Micro HDMI cable connected. Does the RPi4s PWR LED illuminate red when it’s plugged in?

Yep, the PWR LED lights up constant red, and the green LED keeps flashing.

My kid is always stealing my MBP power supply to charge his Switch so I know they can work on other devices. Haven’t gotten around to ordering my Pi 4 yet :)

I have a PI 4 on order, hasn’t shipped yet. I couldn’t get a US compatible supply when I ordered it. The official US version and the universal were both out of stock. I added the Micro USB to USB C adapter and will use one of my official Pi 3 power supplies until I can score an official Pi 4 supply.
I don’t own any Apple products so I couldn’t test one if I wanted too.

From what I’m seeing on the Pi foundation forum, the issue is as described in that article linked to above. The one resistor wired to two pins instead of two resistors one on each pin. So its not Apples fault as I had insinuated.

There is also the problem that the Pi 4 will not boot unless you have an HDMI monitor plugged in, even if VNC is installed & working. Is there an answer to that anywhere?

Further experiments: if the HDMI cable is plugged into the Pi, but the other end left open, the Pi4 will boot & connect to vnc, BUT - one gets a message saying “Cannot currently show the desktop”. One must then connect the hdmi cable & switch on the monitor to do a proper shutdown, I tried to, but th emonitor would not respond - pulled the power plug.