Raspberry Pi 5 Nvme socket

I bought raspberry pi 5 and have tried to connect the pimoroni NVME base with no luck at all - connected everything as in the demonstration video - booted the pi and could not see anything - took it all apart and tried again and managed to break the small plastic clip that holds the ribbon to the slot on the pi - I then secured the ribbon with a small piece of card (as advised in a google search) - everything seems connected but still nothing showing after reboot - I edited the config,txt as shown on “explaining computers” youtube still nothing showing - tried this with two different M2 drives. Not sure if the missing clip is the problem though - Is it possible to get a replacement retention clip?

I Installed Raspberry Pi on to a sd card then after booting from the sd go to imaging top left menu and select Raspberry pi5 and os Raspberry pi 64 then choose where to install and it should show the NVMe drive, once installed switch off remove sd card and reboot … should just boot off the NVME drive All good

Kind regards