RESOLVED: HDMI 8" IPS LCD Screen Kit: "no signal" (yet turns on with Pi 5 boot)

Hello gurus,
I picked up an HDMI 8" IPS LCD Screen Kit (1024x768) fairly recently and used it with my Pi 4 for about a week successfully. After that, I was getting a “No Signal” message on the screen after booting (it would turn on though when booting). After a number of tests and sadly no other HDMI screen to cross-check with, I decided to get a Pi 5 as that was on my list and give that a shot. I’m getting the same results.

However, I WAS able to boot and access the desktop once, so I know I’m close to something good. May I trouble you to help me troubleshoot? :)

The Pi 5 was installed with the Raspberry Pi Installer from a PC, Raspberry Pi OS 64-bit.

I added these settings to config.txt (which may need to stay, change or go):

# CUSTOM display

Here’s the whole config:

# For more options and information see
# Some settings may impact device functionality. See link above for details

# Uncomment some or all of these to enable the optional hardware interfaces

# Enable audio (loads snd_bcm2835)

# Additional overlays and parameters are documented
# /boot/firmware/overlays/README

# Automatically load overlays for detected cameras

# Automatically load overlays for detected DSI displays

# Automatically load initramfs files, if found

# Enable DRM VC4 V3D driver

# Don't have the firmware create an initial video= setting in cmdline.txt.
# Use the kernel's default instead.

# Run in 64-bit mode

# Disable compensation for displays with overscan

# CUSTOM display

# Run as fast as firmware / board allows

# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.


The screen is neatly mounted to the box it shipped in using elastic cording (work in progress…). The ribbon connected to the screen does a 180 degree wrap where the ribbon is connected to the screen controller mounted on the back side. I tried removing and plugging that ribbon in again so far. It looks straight.

I tried disconnecting and reconnecting the HDMI cable on both ends, and the HDMI to [micro HDMI?] adapter where the Pi connects. This is honestly my biggest suspicion now (try new cable and adapter?)

HDMI is connected to the Pi’s HDMI port closest to the power source.

After doing all that while writing this post (don’t want to waste your time!), I now boot and see a black screen (no “no signal” message) for about 10 seconds before it turns back off.

Before I go buy a replacement cable, would you have any other ideas on what might be happening?

Thanks for taking a look in advance!

Best regards,


I figured it out! It was definately the cable. I was able to find a micro HDMI to normal HDMI cable (without an odd adapter in-between today) and all is great. I’m resonding to this forum post using my Pimoroni screen!

Please have a very awesome day.

1 Like