Rotary encoder breakout arrived, but If it’s connected to the correct pins (1,3,5,7,9) the pi won’t boot, the red light turns on when powered up, but won’t boot unless i remove the connector. I assume this is not intended behavior…

DO i need to so something to prep the pi before connected the breakout? I have activated i2c overlay, i’ve switched gpio-shutdown to pin17, tried with a fresh raspbian…


Try it on a stock default Pi Setup. Pi OS and only install whats needed to use it.
Also, how are you wiring it up? Jumpers? Did you solder a header onto the breakout, if yes what does the soldering look like?
Might want to post a picture of the hookup / layout.
It sounds like there may be a short between some of the pins?

connected it with Dupont 5pin wire harness, the pins/wires all check out, i also tried soldering an angle connector to the breakout, and plugging it directly onto the header with same results.

Tried it with a fresh PiOS, on a different PI4 with no hats or shims. Turned on i2c via raspi-config, rebooted, shut down, connected breakout, pi won’t even power up, boots as soon as I pull off it off the header.

I’ll get a pic later, i can’t imagine what it could be besides something very wrong with the microcontroller on the breakout.

I’m thinking that breakout has a fault?

i’ll isolate each pin and see which is causing the problem. too lazy to make some dupont connections, i’ll just order a bunch and check it when they get here.

GPIO 3, Pin 5, by default is the Pi’s startup pin. If you shutdown, and don’t remove power to the Pi, momentarily grounding that pin will signal the Pi to boot up. I don’t know what happens if you hold that ground though?

Using that same pin to signal a shutdown is optional via that dtoverlay entry. I hardly ever do that as I almost always have i2c in use. I use an alternate pin for shutdown.
On my fanshim I use the following.
It’s button grounds GPIO 3 and GPIO 17 when pressed. It can do shutdown and boot up.

got my jumper jerky from amazon. As soon as i hook up 3v3 and ground pins to the corresponding on the breakout board, pi shorts out. Must a faulty controller on the breakout, guess i need to contact support. Thanks for the help.

Thats not good at all! Usually a fault like that blows the 3.3V regulator on the Pi.