RP2040 boards not showing in COM list

Hi all,

Hoping someone can help with this weird issue.

Using the arduino ide with the ‘arduino-pico’ board library (GitHub - earlephilhower/arduino-pico: Raspberry Pi Pico Arduino core, for all RP2040 boards). Having a issue with uploading anything from the ide to any of my rp2040 boards (aside from one, more on that later). I’m using the newer 2.0.2 ide, 2.6.3 of the arduino-pico board lib. Initially every one of my boards worked flawlessly, issue has crept onto almost all of my boards (4 of them).

I installed arduino-pico as per the instructions. Uploaded my first sketch with the ‘Uploading the First Sketch’ instructions (forums won’t let me put more than one link, instructions found in the github page above). Code uploaded, but board would then not show in the COM list. I should note that, on all of these boards, this had worked at some stage in the last few days.

Here are the things that I have tried to resolve the issue:

  1. Tried to re-jig the drivers as per the instructions on the docs using Zadig

  2. Flash nuked each board and started from the ‘first sketch’ phase

  3. Wiped Arduino completely from my system and reinstalled

  4. Since experiencing the issue for the first time: tried on a board that was brand new

  5. Deleted these from devmgr and began from first sketch phase

  6. Reinstalled my OS (win 11). Had a bloated OS so was gonna do this anyway

After OS reinstall I:

  1. Installed arduino
  2. Installed ‘arduino-pico’ as per the instructions
  3. Held bootsel and plugged in a board
  4. Uploaded a known working sketch via Tools->Port->UF2 Board

After trying the above, the board would still not show in the COM list, and the only way to upload is via putting the board into bootsel. Furthermore, windows started showing ‘USB device not recognised’ errors upon plugging in a board.

Interestingly enough, I installed arduino + the arduino-pico lib on another pc and the upload works from there perfectly. Once plugged back into my main pc, the connection briefly worked, before windows started spitting out those ‘USB device not recognised’. To me this sounds like some weird driver issue.

Has anyone experienced an issue like this? Is there any way I can get windows to properly communicate with my boards?