Screen fades to black 10"


Just built my picade yesterday and having troubles getting it to work very well at all. At first, i couldn’t change the volume in settings, whenever I changed it and got out of that menu it just reset to 0.
Playing ROMs worked tho, only problem is the volume is BLASTING at 100%.

I found a solution that is to remove the line: “dtparam=audio=off” from /boot/config.txt.
Very well, I can now change the volume and it saves as it should, but now when i try to start a ROM (or when going into some option menus from the retropie configuration interface) the screen just fades to black. Nothing happens until i press the power button which turns off the machine as usual (screen gets filled with the usual “turn off texts”).

I don’t really know what to do, I’ve tried reinstalling a couple times but am running into the same issue again and again.

I should clarify, I’m using a Raspberry pi 4, with the official power plug.

I’ve been experimenting with changing some of the different settings in config.txt, but no luck. I’ve at least figured out I can put the “dtparam=audio=off” back which makes the machine work, just that the volume gets turned up to 100.

Have you tried the suggested settings in the ‘adjusting the volume’ section at the end of the tutorial?

Those got my volume behaving properly, I didn’t have to do anything with config.txt.

Oh wow.
How embarrasing, I must have missed that part! Thank you, now everything works perfectly!

1 Like