Servo2040 crash

I’ve just got my first Servo2040. I’ve attached an SG92R servo, and I’ve installed the latest firmware (pico-v1.20.1) and tried to run the single servo example (pimoroni-pico/ at main · pimoroni/pimoroni-pico · GitHub)

Servo 1 spins very briefly then the board seems to crash and Thonny loses comms with it. Thonny reports:

PROBLEM IN THONNY’S BACK-END: Exception while handling ‘Run’ (ConnectionError: EOF).
See Thonny’s backend.log for more info.
You may need to press “Stop/Restart” or hard-reset your MicroPython device and try again.

Process ended with exit code 1.

HOWEVER: If I attach a continuous servo (FS90R), no error occurs.

Further info: if I comment out lines 16-26 (go to min, go to max, go to mid), then sometimes the sine sweeps will start, but then the code crashes as the stepped sweeps are supposed to start.

I’ve tried pico-v1.19.16, but the result is the same. I’ve tried a different SG92R servo but the result is the same. Both servos work fine with the Inventor2040.

Am I doing something wrong?