[SOLVED] Fullsized Skywriter Problem


#1

Hello!
I am having some weird behaviour with the full size skywriter. When I run the demo on the Raspberry Pi (test.py) x, y and z coordinates are not detected nor shown. Also taps, touches and double taps rarely get detected, and when they do, it reports a wrong location. (For example, tapping on north, and the demo printing it happened on south)

Wiring has been double checked. As I am a new user, and therefore can’t upload images, here’s a imgur link with photos of my wiring wiring

What could be the problem?

Thank you


Skywriter xl - raspberry pi 3
#2

So, any ideas on what’s happening?


Skywriter with Arduino: Getting started problems
#3

Ahoy! Sorry for the delay. I’ve been swamped in all manner of things and haven’t had a moment to hook Skywriter up to a Pi and see what happens.

The Pi library should work with the full-sized Skywriter, and your wiring must be fine or it’d simply clonk out and complain about not being able to communicate at all.

It’s possible you’ve got a bad firmware flash on your board- it could be running the HAT version of the firmware.They’re all tested before we package them up, but I don’t want to rule this out as a possibility.

Fortunately, this is fixable in the field. I’ll PM you a link to the firmware flasher and some instructions and we’ll see if we can get it up and running!


#4

After flashing the firmware you sent me, everything’s working perfectly. Thank you, @gadgetoid :3


#5

Thank you! I wish more people would tag up as [SOLVED], it’s genuinely helpful for users and one of the things I need to dig through the forums and do.


#6

Sorry, but I’ve the exact same problem. Could you help me as well? Thanks


#7

This is the solution gadgetoid sent me some days ago. I don’t know if the firmware is still on the server.

Edit by Gadgetoid: Warning to any future readers, this firmware is for the full-sized Skywriter only, NOT the HAT!


#8

so, that’s the only way to upload the hexdump to the MGC3130? okay. thanks. the code was still there, i need to setup a Pi for that, thanks for the help. i’ll update you, when i get there. probably tomorrow.


#9

Aye, it’s the only way we can support currently. The normal upload process involves a Windows app and configurator which can’t talk directly to Skywriter at all.


#10

I’ve successfully uploaded the hex-blocks. Restarted the Pi, and tested with test.py.
The results are however different but the device is still not behaving right:

  • Position info is coming only when my palm is almost touching the surface, Z coordinates are always 0.
  • Touching/Tapping East, West and Center works, but North comes always together with Center.
  • If I leave it for a couple of minutes a bunch of sudden position coordinates are coming with mostly X=0.999999, Y=0, Z=0.99999.

What do you think?
thanks in advance,
m.


#11

Thanks for trying! I think we’d better sort you out with a replacement since it’s still not working. Drop a mail to support, reference this thread and they should sort you out. Sorry :(


#12

Hello,
I have similar problems with my Skywriter (fullsized).
First I had rarely any output (like @NiXijav described in the first post).
Then I uploaded the firmware update and it fixed the electrode location and I get coordinate data but I still have some weird behavior:

  • the MGC3130 seems to “lock up” after a few minutes and isn’t sending any data or responding to any I2C messages. (not even “ACK” after the address). After some time it starts to work again.
  • after a reset (power cycle or MCLR) the MGC3130 is often in this lock up state for several minutes
  • the coordinate output is very unstable: all axes tend to randomly write only 0.99999 for several seconds or are only responding to a small part of the sensor area and then they are working fine again for a few seconds.

I tested it with the Arduino and Pi libraries and my own little Serial to I2C Bridge and probed the Reset, TRFR, I2C and Power lines but they seem to be ok.
So I think this is a MGC3130 firmware problem.

Thoughts on that @gadgetoid?
Thanks for any help!


#13

This is odd. I’m looking into it, since it might be related to an issue reported with the Arduino library where I’ve left the reset pin flapping in the breeze. But it’s freezing for you on the Pi too?


#14

I’ve tweaked the reset behaviour of the Arduino library. https://github.com/pimoroni/skywriter-hat