Skywriter + Pi3


#1

Skywriter not responding unless I touch board( ie tap, double tap, touch etc). I am using latest raspian and brand new pi 3, brand new skywriter. I am not sure what I can do to fix. Purchased 2x skywriters and new pi in pursuit of a working version of this. Has anyone actually used this hat on Pi 3? When you run test are you supposed to get x,y,z (I only get when I touch very top of board)?


#2

Yes, x,y,z output would be expected as soon as you place an object above the field within 0-5cm

… I have definitely tried a Skywriter on a Pi3 fairly recently, though that was with the 0.0.5 library. I’ll try to get some testing done next week with the latest, but as far as I know there is no incompatibility.


#3

What is the ‘the 0.0.5 library’, Could I try that. The Skywriter has been an elusive siren. Thanks for the reply.


#4

It’s the previous version of the lib. You can download it from the following url but if you want to give it a go. Not sure what the exact process is to downgrade cleanly so you might be better off trying on a fresh clean image:

https://pypi.python.org/pypi/skywriter/0.0.5

… not that I think it will work any better for you, but who knows.


#5

I have the same issue as open. Watching this thread for an update.


#6

Ditto!
RasPi3, recently update Raspbian, installed everything as instructed.
Through SSH, running sudo ./test.py, only get a flick once in a blue moon and not getting the coordinates at all. Did get a “flywheel or two” after several attempts. Touch/tap does work.
Through VNC, the theremin.pd patch produces the same frequencies, no change, regardless of movement (or tap/touch).
Have yet to try the other scripts (no access to a Pi-friendly screen, right now).
Might indeed downgrade the library and/or install it from scratch. Could also try with a Pi2 and a projector.

Prepping for a workshop on sound control at Montreal’s Raspberry Pi club (Club Framboise) and the Skywriter HAT could be the pièce de résistance, but it needs to work reliably.


#7

Thanks for letting me know. I appreciate it.


#8

As a followup…

Tried with 0.0.5 booting from another card (fresher install of Raspbian, with the automatic upgrade sending old config files to the archive). Same issues.
As the Pi3 was hooked to a projector, was able to try keyboard.py and mouse.py. Same thing (only getting any feedback when touching the HAT).

Exact same issues on a Raspberry Pi 2 running on the first card.

Tried installing on Ubuntu MATE and it couldn’t find the library (though the same method did work on Raspbian).

Two more things which may help.
There’s frequently a warning from skywriter.py that the channel is already in use (including the very first time I tried anything). One exception was after I closed a script which was running in IDLE2 (in which case, the channel was indeed in use). Same thing after keyboard-interrupting one of the scripts and running another one.

And the two X scripts repeat firmware info a few times when they get started (1.1.18;p:Hills).

Any chance it’s in fact a firmware issue? This is on a borrowed HAT as mine is making its way to my home. Would probably feel a bit strange updating the firmware on it, though I could probably swap the two HATs.

sudo ./keyboard.py 
/usr/local/lib/python2.7/dist-packages/skywriter-0.0.5-py2.7.egg/skywriter.py:34: RuntimeWarning: This channel is already in use, continuing anyway.  Use GPIO.setwarnings(False) to disable warnings.
Got firmware info
1.1.18;p:Hills
Got firmware info
1.1.18;p:Hills

#9

Another followup…

Received my own Skywriter HAT (since it was in the mail, borrowed somebody else’s to prepare for a workshop). It looks like things are working properly “out of the box” (or antistatic pouch, in this case). So it sounds like my friend’s Skywriter HAT was “dead on arrival” (she bought it in the UK during the anniversary).

Will finally be able to do musical experiments with it (for instance, controlling a granular synthesis patch). Just too bad it wasn’t working for the workshop, as it could have made for a great demo.


#10

How can I re-flash the firmware? I’d like to get the HAT I bought working.


#11

What is it doing, at this point? Do you get “signal” (as in numbers in the console/terminal when trying test.py)?
The original HAT I tested was probably DoA, but @gadgetoid is the one who can send you the firmware. Since it’s a fairly specific piece of code, it’s likely that they control who’s getting it when to make sure somebody doesn’t brick their HAT just for trying.


#12

I bought two hats and have the same result. if I touch top of the board directly I get x, y , z. I am hoping that there is patch or and update to fix it. If firmware update would fix it would be much appreciated.


#13

It’s extremely unlikely this is a firmware issue. It could be that both boards came from a batch that somehow got through QC undetected.

I would contact support@pimoroni.com and ask for a RMA.


#14

I’m the friend that Enkerli is referring too. My first Skywriter was indeed DOA but I was over the 30 days to return it. So I got a second one, and wouldn’t you know it, it has the same issue!
Skywriters do not seem to like me much. I’m also running it on a Pi3 with a brand new Raspbian SD card.
CleoQc


#15

I contacted support and received a replacement Hat – thank you I appreciate it! This new hat registered positions above the board, swipes, and wheels. It worked. I sent back the original. It was definitely broken when I received it.


#16

I sent an email to support. We’ll see how it goes. The first one was bought in April and the second one didn’t come from Pimoroni, so I’ll see.


#17

No answer, from support. Not even an acknowledgment :(


#18

sorry for the delay… we’re in the process of assessing the various issues. I know the production guys are busy with Skywriter at this very moment, testing the profiling and all the units in the warehouse going through a new round of QA.

still, I’ll liaise with support to make sure they keep all those with non-working Skywriter what’s happening and what the next step is.


#19

Hopefully you got the reply to your support ticket yesterday?

Your replacement Skywriter should be on its way!


#20

I have two broken units, will they be fixed with firmware or I need to order new ones? Are you working to get it working on pi?