Skywriter acting funny


#1

I am using my Skywriter (HATless version) with a Pi 2. When I first got it, I remember it working fine. Now, however, it’s being really erratic. Here’s a summary of the behaviour:

  • When I do a flick:
    • Sometimes it works, but only <50% of the time
    • It sometimes reports a tap or a touch instead of a flick
    • It really doesn’t like ‘south-north’ flicks, and won’t report them occuring
  • It sometimes reports phantom flicks (and occasionally taps) when I’m ~30cm away from it at least, not waving my hands around (these flicks, weirdly, are south-north ones)
  • It quite often stops working after recording around 3 or 4 flicks - for a while, it won’t record any more

I have even tried extracting the flick code from test.py, and have put that below.

This time when I’m using it, I have also connected a Energenie Pi-Mote board (with modified GPIO pins) with jumper cables. However, I’ve tried cutting that board’s 5v line, and it isn’t being used whilst the skywriter’s test code is running. What’s wrong?

Here are some close-ups of my setup: https://goo.gl/photos/hJb7U7kp4LrvESeJ6

Thanks for your help.


@skywriter.flick() def flick(position): print("Got a flick!", 'start', 'finish') signal.pause()