(solved) Picade v2: no image & switch not working

Hi, I just assembled the Picade v2 with a Raspberry PI 4 & 32gb NOOBS sd card. It looks really cute and gorgeous, but the pb is the 10’ screen shows nothing. I tried powering the screen with its own USB charger, only to see “No HDMI signal”. I know I should edit boot/config.txt to set hdmi_force_hotplug=1 (I wonder why this isn’t the default value btw), but how can I do this when my only Linux-like OS is the Picade itself? At no moment there a prompt which would allow a sudo nano boot/config.txt. I pluged the SD-card on my Windows 7 PC, but it only shows some files, no “boot” folder.

Another (maybe related) problem: the Picade switch doesn’t light up. I directly pushed the PI switch and witnessed some LED activity so figured it worked anyway, but the Picade button has no effect. I triple checked the instructions though.

Thanks for any help/suggestion.

If the screen is being powered by a separate USB charger you shouldn’t need to edit the boot/config.txt file. Just switch the Pi on, and it should detect the screen correctly.

As you say, the problem could be related to the Picade switch (I assume you mean the on/off switch?). It could be a bad switch, or wired incorrectly. When you turn on does the white LED on the XHAT come on and stay on, and ditto for the red LED on the Pi?

You should also be able to turn the system on by pressing the SWITCH button on the XHAT (that may be the one you refer to in your last paragraph).

Another option to test things and debug is to try plugging the system into a TV using a long HDMI lead.

the config.txt that you see from Windows is the same file as you later see in /boot in Raspbian.
So you can edit it from Windows.
In general, if editing alinux text files from Windows it is best to use Notepad++ or some other editor that knows about Linux line endings.
(Recent Win10 Notepad was supposed to be aware but I’ve not tried it).

Alternatively … plug in an Ethernet cable and connect to your LAN and then ssh (e.g. using Putty) to the RPi from Windows and then edit the file from within Raspbian.

Don’t you have to enable ssh on the Pi before you can access it? I’ve always had to do that after a fresh install, although I’ve not done one for a while, so it my be turned on by default now.

Well… strangely, it now works! I mean, at least the screen now shows the PI desktop when the screen is powered by external alim, and the Picade on/off switch works too, once I push it really hard. Maybe I pressed if too lightly before. Before that I plugged the Picade screen to an external console and it worked.
I still can’t see the config.txt file nowhere once on Windows (it is set to show hidden files). Here’s a capture:

I suspect Windows added the “System Volume Information” folder, which I can’t delete (maybe it’s possible once on Raspbian).
Now that I can see what I’m doing I guess it’ll be easier to change hdmi_force_hotplug and get rid of that external power unit. I’ll tell you, thanks for your replies!

So I uncommented the hdmi_force_hotplug to set it to 1, turned the PI off, unplugged the screen alim, booted on, but screen is still black, until I replugged in the external alim. Then I wondered how the screen receives power, as I could only see 3 cables to the display card:

  • HDMI cable to PI
  • Narrow ribbon cable to screen controls
  • Large ribbon to screen itself
    Well, I just missed the part where you’re supposed to plug a USB port from the PI to the display card :D.
    In the process the screen clearly showed some ugly hair trapped behind the screen glass, back to screwdriving.
    Pb solved, thanks for your help guys!