Speaker pHAT, drum and piano raspi pi3


#1

I have my piano hat, drum hat and speaker pHAT attached to my raspberry pi 3. I followed these steps below

https://learn.pimoroni.com/tutorial/sandyj/build-an-itty-bitty-beat-box

It worked perfectly. I changed speaker pHAT’s and it didn’t work. Then I put the original speaker pHAT on and it worked. Is it the speaker pHAT that is the issue or do I need to reboot or add the script again?

Lastly, the lights are not working on my speaker pHAT. I used the solderless hammer headers. Help and thank you in advance.

Hammerless headers I used. https://learn.pimoroni.com/tutorial/sandyj/fitting-hammer-headers


#2

Two speaker pHATs should work with the same setup. Sounds like it may be the Speaker pHAT that is the issue- or the header

The lights not working could be a software issue, or a problem with the connection. Could you post a photo of your setup? Closeups of the header on the pHAT?

Also might be worth including the contents of /etc/asound.conf and /etc/pulse/default.pa


#3

The assembled photo is with the one hat that works. The picture taken alone is with the one that doesn’t work.


#4


#5


#6


#7

Thanks I fixed the light issue. However when I attach my second speaker phat, the lights come on but no sound.

What do you think is the issue? I’ve done all the scripts. Soldering?


#8

Could you post a picture of the top soldering for the non-working Speaker pHAT?

I can’t see anything immediately wrong with it. Soldering is usually the culprit in these cases.


#9

The first picture I posted shows the soldering on it. Otherwise for all the pins, I used the solderless hammer on piece (which on delivery has missing pins I had to put back in)


#10

D’oh, that’ll teach me not to read up. It’s highly possible the displaced pins could be causing a problem. Could you post a photo of the top-side of the speaker-phat? Are the displaced pins… well, still displaced in any way?

If I can’t spot anything, then you should ping support@pimoroni.com for a replacement (pHAT and hammer header) and point them to this thread.


#11

I put the pins back into place the best I could. Visually it looks okay but obviously something isn’t right. The other speaker phat I have works fine and I followed the same steps.


#12

I think an email to support is probably the best way to go now :( Sorry you appear to have received either a dud board or the header just isn’t making contact properly.


#13

I ran this and seems an error on pin 4. I’ve emailed Adafruit and Pimoroni. Any chance someone in the thread can help me out and get this taken care of. It just isn’t working. Lastly, thanks for all the help. Been amazing!


#14

This looks like an i2c IO error- IE: the Pi is failing to communicate with one of the touch chips on Piano HAT.

Is the hat placed directly on top of the Pi in this instance, or is it connected via the pHAT Stack?


#15

It’s on the phat stack


#16

Does it work if you attach it directly to the Pi?


#17

Just tried and it doesn’t. :( I think it’s shot. I hope they send me a new one. Thanks for all the help.