Speakerphat vs Phatbeat, functionality


#1

Hi, I got my PhatBeat to work to satisfaction, listening to some finnish streaming radiostations, Great. I have built a stereo radio with two speakers.
Now I want to build a small size mono-radio based on Speakerphat utilising the small speaker because the sound quality of the streaming source (hamradio on 3699kHz) is quite poor.
I had in mind ; ofcourse not understanding the functionality of the speakerphat, that this could be achevied using the same procedure as with PHatbeat with a taylor made playlist. So, how can I define which source the Speakerphat should stream as there is no default playlist available.
i am still in the learningphase understanding the speakerphat. I am sure I have missed something on the forum so please guide me in the right direction
BR
calleblyh
Helsinki/Finland


#2

Hi again,
Over the weekend I did by mistake connect Speakerphat to my RPi0W but I forgot to change the SD-card ( with PhatBeat sw) so after boot it was running under phatbeat sw. I could hear the sound of the station in playlist, but the volume was next to nothing, but still audible. . Is there a simple way to control volume?
Based on this experience could you make a special version of phatbeat to run streaming to speakerphat ? This request is based on my first idea how I expected speakerphat to behave allowing streaming of radioprograms to a very small and compact setup of RPi0W + SpeakerpHat.
Maybe this is already available, but my programming skills are not mature enough…

Any ideas from your side appreciated


#3

I actually have a work-in-progress version of PiratePython for this, which you can find the pHAT BEAT/Pirate Radio version of here: http://get.pimoroni.com/pirateradio-v20171113.zip

This you should be able to extract to a fat32 microSD card, configure your wifi by editing wifi_supplicant.conf and just plug it in a Pi to have it fire up and start playing.

This same software will work with Speaker pHAT, but would ideally need some changes to drive the LED VU Meter since it’s configured only for the pHAT BEAT one, and to remove the software that reads pHAT BEATs buttons, since Speaker pHAT doesn’t have buttons.

Speaker pHAT is definitely a lot quieter than pHAT BEAT with larger speakers- depending on your audio source you may be able to increase the volume in alsamixer or in the application generating the audio.


#4

Thanks for your response. I did as told. On boot I get a “horror piratepython” graphic followed by
Pirate Python Alpha (Raspbian Stretch) - piratepython tty1

IP Address: 192.168.1.2 ( seems correct to my wifi network )

piratepyhton login: wired usb keyboard no response nor can I ssh into RPi0W. However I can hear something from the Speakerphat loudsåeaker but very very low volume

This result from first attempt


#5

SSH should be enabled via default with username pirate and password p1r4t3.

This is a headless-only distribution that boots in USB slave mode, so no USB devices have been tested with it yet, and most likely wont work.


#6

Thanks,
Login is okey now.
I will later today do some tests with both phatbeat and speakerphat


#7

Ok, it took while to learn the “secrets” behind phatbeat and speakerphat.
Yes, this work-in-progress seems quite an interesting approach. I have checked with phatbeat vu-meter is ok as well as pushbutton ctrl. In Speakerphat I would appreciate keeping software for pushbutton ctrl as it is in this early alpha version, because it is quite easy to connect directly to appropriate gpio-pins. VU-meter needs to be accessed ! For a non-programmer like me I would need to know where to change the file containing playlist ?
Please keep me posted on developements


#8

For the Pirate Radio “firmware” style, the “playlist.m3u” file just sits on the root of the SD card. You can plug it into a host computer to edit it, or even (your mileage may vary) plug the Pi into a computer via USB (into the host port, not the power port) and it should mount as mass storage.

Edit: And I’m hoping to make these things less “secret” and more “the way it’s done”