Strange blinking line at top of 7" screen


#1

My Raspberry Pi 7" Touchscreen Display arrived a few days ago, with Jade cover.
Pimoroni Ltd parcel number 15505356711121
order #RASPI-24377 via Pi Swag

Got it up and running with little fuss (after upgrading the firmware and flipping the image right-side up) and appears to work quite well in terminal/text mode, but has an annoying white bar that blinks along the the top of the screen when i use the GUI (via startx). See video link for ‘live demonstration’: https://youtu.be/YCx9pve5RyI

Touch events seem to work, and I got the right-click (holding finger down a little longer) trick working - as seen in the video.

Anything I should be looking at? Almost get the impression it’s running at too high a resolution, but wanted to post my concerns here before I started tinkering with config files.


#2

Tinkered with framebuffer resolution (400x320), commented out ‘diasble_overscan=1’ just for the heck of it. No change so far. Hopefully the board is not broken! :(


#3

Nothing wrong with your display, Looking at the video, you do not have the ‘normal’ desktop.
The flashing bar, is where the menu bar should be. I only see the trash can on your desktop.
Have you adapted your desktop? Is this still on Wheezy or on Jessie?


#4

Should be whatever was on the Rasbian NOOBs SD card when it was installed. Actually haven’t used the GUI until this past weekend - up to this point the Pi was used as a little web/ftp server and access was all done by ssh and ftp. No ‘adaptation’ of the desktop has been done because it was never used until now.

At work now so hard to check (it’s not running as a remote server at the moment), but if I recall, the Pi should still be on Wheezy. Haven’t done a distribution upgrade.


#5

You should re-image your SD card. There might be a way to fix it by reinstalling packages, but a re-image will be easier.

@tvoverbeek is correct. The white flashing line is the menu bar, which looks like it’s stuck in a permanent restart loop.


#6

Will give that a try this evening. Thanks for the input! Will report back success or failure.


#7

For some reason, several attempts at getting NOOBS installed on the 32GB SD card failed - and yes I scoured the net quite thoroughly and came up with 2-3 different methods of getting the card formatted and transferring the contents of the NOOBs folder to the card, but it still would not boot - regardless if I did the work under Windows or Linux.

But putting the latest Rasbian Jessie image on the SD card worked like a charm and the Pi booted up and auto-logged in without trouble and - more importantly - without the blinking menu space seen in my video posted earlier in this thread. Touch events worked ‘out of the box’.

Now just waiting to see if the ‘right-click’ issue can be solved for Jessie ( related to https://www.raspberrypi.org/forums/viewtopic.php?f=108&t=121602 ) Of course that is for another thread!

Thanks for your input!