Streaky inkyphat


#1

My new ‘inkyphat’ seems to be a bit broken … it looks like an ink jet that’s running low on ink

I’ve cycled it though several filled white, red and black fills, and it seems to be getting worse.

Any ideas?

Thanks.


#2

Yikes, that’s definitely gone a little wrong.

Try gently lifting up the black clasp on the ribbon cable connector and re-seating the ribbon to see if it fixes your problem. The black part should lever upwards toward the ribbon cable to release it.

Let me know if that doesn’t work!


#3

OK, just done that, no change unfortunately


#4

Thanks for trying, anyway!

Can you drop me a forum PM with your order number, and I’ll put the replacement process in motion! We’ll definitely need to get this one back for testing. Sorry for the hassle!


#5

Hi, mine’s gone in a similar way, had it a couple of days. Was great to start with, then in the last couple of hours I’ve noticed it’s got streaky:

Have reseated the ribbon cable to no effect. Not getting any better with refreshing the picture.

(got another couple of pics of it but the forum won’t let me put more than one picture in)


#6

Seems to be a progressive fault, it now looks like:


#7

Same problem here. Mine worked like a charm the first few days, very pretty. Yesterday I noticed an unexpected line across the display. Today, it’s worse…


#8

Same for me, first two days it worked fine. Then I had one dead line, then two. Now it looks like this:

At first it would sort of “revive” some of the lines if the colors changed enough so I wrote a script that randomly replaces the whole screen with one solid color every couple of minutes but it just won’t fix it. It’s not visible in full black or white only in full red.

When I display stuff like the calendar example it’s missing pixels in white on the black background and looks streaky as well. My main project has white background and draws in black and red and that’s streaky as well.

EDIT:
Before I sent it back this morning the dead lines started to show as red in the solid black image. Really weird.


#9

Same problem for me. The first few days, there was no problem, then some “dead lines” appeared.


#10

Ahoy! As you can imagine we’re sad to see so many streaky Inky pHATs and we’re working right now to get to the bottom of the problem.

Please, if you’ve been affected, send us an email to support@pimoroni.com - this is the best way for us to keep track of who’s been affected and manage sending out replacements.

Thank you!


#11

Ahoy ahoy!

Could you folks with misbehaving Inky pHATs give us some more details of how you’ve been using them, to help us narrow down what might be the root cause, please?

  1. On what sort of Pi has your Inky pHAT been running?
  2. How have you been using it? i.e. what script/s have been running, how often have you been refreshing, etc.
  3. What sort of power supply have you been using?

This morning, we’ve set up a bank of 5 Inky pHATs refreshing every 30 secs and will be monitoring their state over the next few days .


#12

Sadly, my replacement has also failed in the same way

Basically I’ve got the InkyPhat plugged into a Pi Zero W, (there’s also a camera attached)

power supply: it’s plugged into the back of a Sony bluetooth speaker

I’ve got it standing on it’s edge, power lead at the top, so generally the display has been inverted.

Mostly, it’s just running a slightly modified version of the weather example that I’ve dropped in /etc/cron.hourly

I’ve tested it with various filled solid, and checker board patterns with black, white, and red fills; generally when I’ve been testing it, the refresh would have been no more than once every 30s

It ‘appears’ to be the red that fails first; although once it’s gone you can’t write black pixels to those lines either. Strangely, a solid black fill seems to work regardless, however a red fill will show all of the failed areas.

thanks


#13

For me

  1. Raspberry Pi Zero W
  2. I was developing some code that displays a thermometer on the pi in a portrait layout. It took a lot of refreshing to test where the lines should go. Refreshing every couple of minutes until I got it right. By day two there had already been a dead line but that vanished every now and again so I didn’t pay much attention. By day three I had it set up to refresh every five minutes and not long after that the lines started getting worse.
  3. Currently using a USB port on my router to power the Pi. No problems there. For every other Pi I have official power supplies ordered through you guys and it happened with those too.

What exactly is it refreshing? I hope it’s something like the calendar example with thin lines.


#14

Hi,

Same issue for me. I’m waiting for a replacement one, we’ll see.

Here are the details:

  1. Raspberry Zero W
  2. Weather.py refreshed every 20 minutes. The issue appeared after less than 24h.
  3. Samsung usb power supply 5V 2A

Lionel


#15

Ahoy maties. Support have sent me a new one, I’ve posted the streaky one back so hopefully that helps solve the mystery.

  1. Was in a Raspberry Pi Zero (original, not W) with https://shop.pimoroni.com/products/usb-multi-function-lan-adaptor + the official raspberry pi wifi dongle + a Bluetooth dongle.
  2. Tried the examples and then put it on weather.py once per hour.
  3. Raspberry Pi branded power supply, the white 2A one that came with the pimoroni “Pi Zero Complete Starter Kit”.

#16

Details for me:

  1. Raspberry Pi Zero (no camera, no WiFi)
  2. Use only the example provided in the library (hello.py, weather.py, cal.py and logo.py)
  3. Power supply from the computer

#17

I haven’t had a chance yet to try out the replacement one I got but I’m a bit wary as someone else reported their replacement failed also. Has anyone’s replacement stayed working after several days of use? Has anyone had issues on a non-Zero Pi, or is it just coincidence that everyone’s reported being on a Zero since it’s the ideal size for one?


#18

I wondered this, too, so I’ve been thrash-testing them on a Pi Zero W. So far I’ve been unable to draw any concrete conclusions, but it doesn’t appear to be specific to the Pi Zero. Testing continues!


#19

I got an email today asking me to update the inkyphat software. Could someone please go into more detail what these “errors” that it’s supposed to prevent are? Still waiting for my replacement inky but I’ve updated the Pi on which I’ll use it just in case.


#20

The new version changes the Inky pHAT library so that it fully initialises and then fully shuts down Inky pHAT before and after every update. This is to make it near identical in functionality to reference code. While it doesn’t “fix” anything per se- it’s a precautionary update to try and eliminate anything the software might be doing from the equation.

You can see the relevant parts of the changeset here: https://github.com/pimoroni/inky-phat/commit/5b464a46c29292fecc70033aac6164119b515684

Note: The 8 lines of technobabble that were removed from 95-102 were LUTs - look up tables- that were being transmitted to the device, but unused since it was configured to use its internal OTP LUTs anyway. Those are just spring cleaning that has no bearing on this change.