Three Port USB Hub with Ethernet - microB connector vanishes and I lose connectivity


#1

I’ve emailed Pimoroni about this as well but thought it worth posting here.

I’ve just taken delivery of a Pi Zero (not W) and a “Three Port USB Hub with Ethernet - microB connector”.

While trying to update a new Stretch SD card, I’ve experienced lots of problems of just losing connection to the Pi. I can leave a continual ping going, after a while, it just stops.

By a process of elimination I’ve traced the problem to the ethernet adapter.

At the moment I have this adapter plugged into another Pi Zero (this time a W) which I’ve connected to via WiFi.

While trying to install snmpd, I lost connection via ethernet again but I’m still connected via WiFi.

ifconfig shows eth0 has vanished.

I’ve used multiple different PSUs including an official Raspberry one and about three different cables.

I’ve plugged into different ports in my router and used different ethernet cables.

Has anyone experienced this? The Three Port USB Hub with Ethernet - microB connector just effectively disappearing into thin air.

The lights in it are still on and so is the activity light on the router.

Any thoughts please? Faulty part, maybe?

Keith.


#2

Could be a flaky USB connection or power supply?

What power supply are you using?

Do you see anything useful in the output of dmesg when the eth0 device disappears?


#3

I’m just about to head out so will check dmesg later.

I’ve tried three or four different PSUs, including the official RPi one. They’ve all worked perfectly well with other Pis (I have around fifteen or so in the house doing ‘stuff’). I’ve also used different USB cables between the non RPi PSU and the Pi. I’m pretty sure it’s not a power issue.

USB could be flaky but that would be within the Three Port USB Hub with Ethernet adapter rather than the Pi because the symptoms are the same on two different Pis.


#4

If this is the HUB your using, https://shop.pimoroni.com/products/three-port-usb-hub-with-ethernet-and-microb-connector
I just ran sudo apt-get update, sudo apt-get update on a fresh Raspbian Stretch SD card, no issues that I could see, it completed without errors. Raspberry Pi Zero W, WIFI was not configured, update was done via Ethernet. Just a FYI info post. I usually don’t use the Ethernet part of it, other than just the once to verify it works. I like those HUBS, I have two. I also have the one with the normal USB plug, I use them on my Pi A+'s. Usually I have a USB WIFI adapter plugged in when using one on my A+. Update upgrade runs that way without issue too. Again Just a FYI post. I had one so I figured I do my own test. I have no idea why yours is glitching though?


#5

Does Your keyboard and or mouse die when the Ethernet dies? I’m assuming they are plugged into that same HUB. I have a wireless Logitech K400 keyboard with touchpad plugged into mine.


#6

Yes, that’s exactly the same Ethernet adapter/hub I’m using.

Never assume anything though - I connect via ssh. I forget the last time I connected a monitor, mouse or keyboard to any Raspberry Pi.


#7

Ok, I usually only use mine during setup. Once I have everything the way I want it, I unplug it and run that Pi headless. The only Pi I have that doesn’t run headless in my 3B that I don’t need a HUB for. I might have remoted in once or twice way back when I got my first Pi. I haven’t had the need to do that in a long time.

So is the update actually failing or is just your SSH connection being broken / lost?


#8

I feel as though I’m repeating myself here. I’m sure I detailed al this in the original post.

Originally I was testing this with a brand spanking new Zero (non W).

To try and determine if the fault was with the Zero or the adapter, I started a process of elimination.

I grabbed a known working Pi Zero W and plugged the adapter into it. I wrote a new SD card with Stretch, copied ssh and wpa_supplicant onto it and fired it up.

I started two pings going, one via WiFi and one via ethernet and connected to the Zero W via WiFi.

Then I logged into the Zero using WiFi.

Ran sudo apt-get update
Then ran sudo apt-get install snmpd

Part way through the installation, the ping via ethernet stopped responding. Because I was connected via WiFi, I could continue to see that the Zero W was working perfectly. The install carried on.

When the install finished, ifconfig didn’t list eth0 as an available device. The LEDs in the adapter were still flashing, so was the network activity light on the router.

I’ve also tried different ports on the router and different network cables. The only consistent thing in this is the adapter.

So from this, I deduce that the adapter is faulty.


#9

Yeah , sorry about that. I’m a bit of a Linux Noob to be honest. So it’s the snmpd (had to look that up) install that’s breaking things. That’s not something I use. I originally didn’t clue in to the fact that you were installing snmpd separately. I thought it was crashing when apt-get upgrade got to updating snmpd. Now after rereading it I see you were doing that separately. I still have no idea why its crashing your Ethernet port though?


#10

No, it’s not just the snmpd install that’s breaking it. I used that as an example. Originally I was just running a sudo apt-get dist-upgrade when it failed. It can be anything, it falls over at random times.


#11

Ah Ok. I hardly ever use the Ethernet Port on mine. I just find it easier to plug in a USB WIFI dongle for use with my Pi A+. And I currently only have Zero W’s in use. I gave away all my original Zero’s. So I just use WIFI.

I will try a dist-upgrade in a bit, I’ll have to unplug my network cable from this PC first. I don’t have a network switch in this room.


#12

It’s the adapter, absolutely the adapter. I bought a different type from Amazon which has just arrived and is working perfectly.


#13

Just did a dist-upgrade, no issues. Was fine all the way through. You must have got a bum hub?


#14

The adapter was faulty, I’ve received a replacement today and it’s working fine.


#15

That’s good to hear. If it was me I think I’d crack the dud one open and have a look inside.


#16

What, the one I had to send back so they could test to prove it was faulty? :)


#17

Ah, Ok never mind. I didn’t realize you had to sent it back. Sometimes with stuff like that they just send you a new one and don’t bother getting you to ship the dead one back.