Problem with adapter RPi Zero W


#1

Hi everyone,
I’ve just bought this adapter https://shop.pimoroni.com/products/three-port-usb-hub-with-ethernet-and-microb-connector and I have some problems to use the Ethernet port. Indeed, sometimes it’s connected to my own network sometimes not (I check with a ping command).
So I don’t know if someone has already got this same problem ?

Thank you,

Pierre


#2

Do you see any related error messages if you run dmesg on the Pi?

What if you run ifconfig on the Pi- does the USB network interface show up?


#3

I have one of those, Ethernet Port worked fine for me the few times I used it. To be honest I’ve only used it once or twice. Once when I first got it just to verify it all worked, then maybe once or twice after that. I usually have that hub plugged into a Zero W and I instinctively just use WIFI. The few times I’ve used the Ethernet I did updates upgrades of Raspbian, reboots etc with no issues. Maybe try a different network cable?


#4

Thanks for your answers,
I ran dmesg and I have some troubleshooting on my eth0 interface:
pb_eth0
There is maybe a problem with the driver of the adapter ? (I use the last Raspbian Lite OS)

And when I plug it after the RPi is booted, the RPi reboots (I use an enough powerful alimentation so I don’t think it is because of this). alphanumeric, could you say me what does it do for you when you plug and unplug the adapter ?

Thanks a lot,

Pierre


#5

I don’t remember ever plugging it in while the Pi was booted up. I usually have everything all plugged in and then plug in my power supply. I do believe I have seen complaints of Zero"s rebooting when plugging things into the DATA USB port though. I think it was on the Pi Foundation forums?