Trinket Boot mode


#1

Hi, I’m having trouble with my trinket.

I can’t get it into boot mode. I’ve installed the “Trinket / Pro Trinket / Gemma “ drivers from the Adafruit webpage. As I understand it, I should now be able to plug the trinket into my PC and get a flashing red light, is this right?

So obviously I’m not seeing this red light. Is there any chance I could have broken the Trinket when I was soldering on the header, I didn’t test it before I did this and it’s the first time I’ve done something like this. It looks like I’ve done a pretty decent job so I don’t think it’s this.

Any help would be greatly appreciated.


#2

Unfortunately it is quite a common issue, that often occur with USB3 ports, see here: https://learn.adafruit.com/introducing-trinket/faq

What computer are you using? If you have an external USB2 hub available, preferably one that is powered externally, try that as a possible solution.


#3

I’m using a Lenovo W530. Just tried it through a powered hub, still getting the “USB device not recognised” message.

Do you think it is the specific trinket I have or my PC set-up that is the problem? I’ve tried it on another PC with similar results.