Trouble Programming New Picade Key Mapping


#1

I have downloaded the sketch and finally got it to compile without errors, made my changes and saved it under a different name.

I plug in the Picade and Windows detects it as an Arduino Leonardo on Com20

When I attempt to upload the sketch the computer suddenly can no longer recognize the Picade and see it as an unknown device on Com20.

Unplugging and plugging the Picade back in, Windows detects it as a Leonardo again on Com20.

But when I check the key mapping it is still at the Picade default.


#2

I tend to do an in-place update, since removing the whole Picade from the cabinet to update it is complicated. You can do this by locating the compile file, copying it to your Pi and using the updater here: https://github.com/pimoroni/Picade-Sketch/tree/master/update

But if you’re not using it with a Pi try grabbing this file:

Then:

  • Go to “Devices and Printers”
  • Find the Picade ( Leonardo ) and right click on it
  • Pick “Properties”
  • Click the “Hardware” tab
  • Click “Properties”
  • Click “Change settings”
  • Click the “Driver” tab
  • Click “Update Driver”
  • Click “Browse my computer…”
  • Click “Let me pick…”
  • Click “Have disk”
  • Click “Browse”
  • Find the picade.inf file
  • Click “Open”
  • Click “Next”
  • Click “Yes”
  • Click “Install this driver software anyway”
  • You should see: “Windows has finished insta…” “Pimoroni Picade”
  • Click “Close”
  • Allow mouse button to cool off for a moment
  • Cross your fingers
  • Resume Arduino-ing

#3

Nope, the same thing happens.

During the programming the Pimoroni Picade goes away and an unknown device shows up.

Unplugging and re-pluggng the Picade is back but still at the default key mappings

All this really did was change the “name” Windows uses for this device from Arduino Leonardo to Pimoroni Picade.


#4

This is basically because the Arduino IDE resets it, then sits waiting for a new serial port to pop up, and then downloads to that new port. If it can find it!

I’d wholly recommend copying your compiled file hex file over to the Pi and using the “update” script to circumvent the total nightmare that is doing anything with serial ports on Windows.

If you go into settings in Arduino, you can turn verbose compile and upload output on to reveal the path where the .hex is saved. This may also tell us more about why it’s failing to upload.


#5

Okay I will try the update script. I take it I run that on the Pi?

This hex file?

“C:\Users\Bob\AppData\Local\Temp\58e9973bb6e2e908c6c199f5a9d39075.tmp\output/Picade-NES.ino.hex”


#6

I was successful running the updater on my Picade, but I have to hit the reset button.

So that means I can at least program it. Looking in the temporary directory the Arduino IDE makes I see two possible hex files.

Picade-NES.ino.hex
Picade-NES.ino.with_bootloader.hex

What one should I use?


#7

Ahoy.

You should use: Picade-NES.ino.hex

Sorry for the stupendous delay replying, I was ill, and then subsequently immensely busy.


#8

No worries, thanks for the help.