Using Picade board with Windows 7 machine


#1

I’ve built my Picade (great piece of kit by the way!) and installed my mini-ITX motherboard but I’m struggling to get Windows 7 (amd64 architecture) to see the Picade board. Device manager shows an Arduino Leonardo is connected but there is no driver so I get a yellow warning triangle.

I’ve tried the drivers in the Arduino IDE zip, I’ve tried all the solutions I can see on the net. I’ve got it on USB 2 rather than a USB 3.0 port…, I’m out of ideas… Has anyone else made it work with windows?

Help!

Smurphboy


#2

Ha! Solved my own problem. I needed to tell Windows it was a USB Composite Device for some reason and then it figured it all out and installed the CDC and the HID drivers.

Sorted.


#3

I’ve got an inf driver file floating around somewhere that I need to clean up and add to the repo- it makes sure the Picade, which uses our own USB identifiers, is properly recognised by Windows. It’s interesting that USB composite device works too- does it even detect properly in bootloader mode/let you upload code from the Arduino IDE?


#4

Before I’d tweaked it, you couldn’t access it at all from the Arduino IDE. I had to tell it (manually) it was a composite device and then it went and found all the drivers.

I suspect its part of the whole 64bit windows doesn’t really work thing… but I can’t find a decent mini-itx mac motherboard ;)


#5

Hahaha! Brilliant. Although I reckon a whole Mac Mini would fit inside Picade.


#6

Funny you should mention that… I’ve got a mid 2007 mac mini that I can’t upgrade, its the early Intel Core solo motherboard…

Pretty sure it will run mame, et al but pc seems to have more / better arcade front ends. All the mac stuff is mouse configured :(


#7

shudder that’s a shame. But, yes, the PC does get a lot of “the good stuff” when it comes to emulators.

Have you seen OpenEmu? http://openemu.org/


#8

I have, it’s a Jaguar emulator away from perfection…

The real reason for going mini-itx and PC was a fanless machine, I can’t find a way of getting around the mac mini’s fans without resorting to £00s of heatsinks.


#9

Just registered to say thank you to smurphboy.

I wanted my brand new Picade to run a x86 based computer to get more power than the rpi2, especially to get latest Mame versions and also emulators that won’t run on my rpi2 (Dolphin, PCSX2,…). I’m running Windows 7 x64 on a i5 Broadwell NUC for my tests. Installed the picade.inf driver available at github and the board get recognized immediately. Sound +/- working, but no way to get the other buttons and the stick to work. Tried everything like flashing the other firmwares (gamepad and 2016 lastest), but no way to get those damn controls to work in Windows. Game controller panel even showed a 3axis 16 buttons device with those firmwares, but no way to get any input from the stick, even in the test dialog with this device selected. Then I removed the picade.inf drivers from github and declared the board as an USB composite device like smurphboy did. MIRACLE !!! Everything is now working fine.

Will certainly post a full report in a couple of week after everything will be fully installed and configured the way I want it (Sanwa joystick and buttons, 12" screen replacement, miniITX board and CPU also ordered).