Built picade, but is my PCB faulty?


#1

Hi there,
newly confused and looking for some pointers if anyone could be so kind?

I’ve recently built the Picade, screen is working fine. Retropie 3.2.1 boots on the Pi2 and looks OK, but I don’t seem to have any input/output coming from the Picade board so I can’t pass the “press any button to identify your controller” challenge. I’ve connected a Dual Shock 3 which is recognised so I don’t seem to have any issues there.

I’ve wired everything as instruction but I only see a light on the ON led, and on BL if I press the reset button. Any button presses or joystick input does nothing to the board.

Additionally, what is the PCB labelled 800023 and ribbon cable for? I can’t seem to find any mention of them.

(edit, figured that bit out.)

thx!
stx


Picade issues, button presses not found
#2

Just a little update, the PCB doesn’t appear as a USB device to any other PC I have. If I’ve understood it correctly it should show up as a Arduino Leonardo? I’ve installed the IDE but can’t seem to identify the board on Ubuntu 15/64 or Windows8.1/10


#3

The PCB should appear as a USB HID Keyboard and an Arduino Leonardo if I remember correctly. It’s possible you have a duff board if it’s not registering button presses. We test them all, but they can slip through.

Drop us a line at support@pimoroni.com for a replacement if you haven’t already!


#4

FYI: I had the same issue with the provided USB cable. I’ve replaced the cable with my own and it started to work fine.


#5

The same issue here. No input signal. But after changing usb cable all wotking fine.


#6

Thanks, that’s interesting you’ve both seen a similar issue. I’ve tried a couple of different cables though.


#7

I seem to recall using our own VID/PID in the Picade bootloader so it’s possible you might need to use an .inf driver and manually install it. I can’t seem to find said driver, though! I’ll have a dig on my workstation. I’ve got a recollection of creating it and pushing it up to Github, but it’s not there!


#8

FWIW, I received a replacement and it worked fine out of the bag. Cheers all!