PICADE Console support


#1

I just received my Picade console, the build went good but I am having issues with the completion. I do believe that my screen/driver board are bad as it has lines through it and other abnormalities to the screen. I decided to replace it with a 12" HDMI compatible one from Amazon. In the mean time I have it hooked up to my TV. When my system comes up I get the welcome screen and push any button to configure as far as I can tell the “picade” board isn’t responding, could it be a programing issue?" the “on” lamp is lit but no “TX\RX” lights when buttons are pushed. the “BL” light does light up when the reset is pushed. I have checked all connections for the joy stick and buttons (ohm meter) and they are correct and working. Am I missing something in the set up of the retropie? programming? etc.


#2

Curious. It could be a programming issue. What do you see if you connect it up to your Pi, drop to the command line and run sudo lsusb

This should list all connected USB peripherals.

And also, ls /dev/ttyA*


#3

Hi there sir.
Well I already have the picade card connected via the supplied usb cable to
my raspberry pi 3 card. I attached a keyboard and then hit F4 to get to the
screen and input the supplied commands. Please find attached pictures of
the results
V/r Dale


#4

Curious, not a whisper of Picade there. Do you have another USB cable you could try?


#5

i changed out to the usb cable that i use to transfer data from my Samsung
phone to the PC and still have the same indications

i am showing power on the picade. and the reset looks like it works. Is
this board supposed to be “plug and play”?


#6

Yes, it’s absolutely supposed to be plug and play. It should just show up and function like a regular keyboard/gamepad, with each button corresponding to a keypress by default.

Have you tried connecting it to another USB port on your Pi?

P.S. Your AVG installation is adding spam ads to the bottom of your outgoing emails, which are getting posted verbatim onto our public forums. You might want to turn that “feature” off :D


#7

Sorry about that ill have to figure out how to turn it off or switch to “another” one :) So far i do “believe” i have tried all 4 ports. This build has been fighting me from the start. I bought it from a company in the states called “MCM Electronics” thought it was cool… i have no clue what their warranty is like i just know if would cost an arm and a leg to ship back from the Base i am located on. So for me fixing is the best option i think. I have some USB game pads from my previous Raspberry Pi build. ill switch and see if it works that way.
Best Regards
Dale


#8

just on the off chance i tried a 3rd cable still no joy… plugged a USB controller into the “pi” and it was recognized right off the bat :(


#9

A post was split to a new topic: Picade button mapping issue- mapping to speed up?


#10

Thanks for trying everything. It looks like it’s faulty. That shouldn’t happen, since we test all of our Picade PCBs. But, granted, dodgy ones do slip through from time to time when something marginal passes testing but fails in transit, or upon first use :(

I noticed you’ve already got a support ticket in progress, though, and I trust Matt will sort you out appropriately!


#11

i would just like to say that your company is awesome!! Many thanks to Matt and yourself for all the help. As we say “two thumbs up”. i would say that the fault with this would lay in the company on my side of the pond as you never know how they treated it before shipping it out ;) best regards and many thanks Dale