Trouble using TinyFPGA Programmer with AX2

#1

I have the TinyFPGA Programmer and AX2 board, and Windows 10.
When I run the programmer application to download a .JED file, I get the message “Cannot identify FPGA. Please ensure proper FPGA power and JTAG connection.”
Adding debug code to the programmer shows it is receiving status [0,0,0,0] which is not expected from the AX2 board.
(I have soldered headers to plug the programmer into the AX2 and to take 3.3V from the programmer. 3.3V is connected and GND is connected.)
I already tried changing the USB port and the cable.

0 Likes

#2

It might be worth getting in touch with Luke at tinyfpga directly luke@tinyfpga.com

I’ve played around with these on linux but not windows, I know there were issues with drivers on pre Win10 systems (see 4th paragraph here: https://tinyfpga.com/a-series-guide.html)

0 Likes

#3

I may be off base here but I’ve run into issues trying to program my Arduino when I haven’t set the correct COM port number in the Windows 10 Arduino IDE programmer. I have two UNO’s and swapped them, the second one decided to use a different COM port when connected via USB. Uploading a sketch then failed. When I had a look see in Device manager I noticed the COM port had changed. Once I matched it in the IDE my sketch uploaded with no issues.

0 Likes

#4

The programmer is definitely finding the correct COM port but does not recognize the AX2

0 Likes

#5

I was working through this very guide but got stuck at programming the AX2. I’ll wait to see what Luke has to say

0 Likes