Unicorn Hat only has 5 rows light up

Hello. I have a Unicornhat but only the top 5 rows out of the 8 light up. When the code runs it seems to think all 8 rows are working as I don’t get any errors, yet the bottom 3 rows stay dark. I’ve tried this on a Pi 4B running Raspbian and also Ubuntu, as well as on a Pi Zero W running Raspbian. In all cases, I’m able to run the example programs in the Github repo but only 5 rows light up and the other 3 are do nothing. I tried telling the code to rotate 90 degrees, which it does, but the 3 rows that were dark before are still dark.

I don’t think this is a case of interference from something else. I’m not playing any sound, I tried removing the sound drivers completely, and I tried plugging in an HDMI monitor. There’s no interference on the LEDs either: they’re all dark when I’m not running the python code and the 5 rows light up perfectly when I run the example code.

If I set the code to think it is a PHAT, the top for rows light up properly.

Has anyone seen this before? I’ve been using a Rainbow hat on my Pi4b and Pi Zero W for a few months now with no issues so I think I’m using the Unicornhat correctly. Maybe it’s defective?

Sounds like its defective to me? You can e-mail Pimoroni directly vis the following link.
I’d put a link to this thread in that e-mail.

It sounds like 1 LED in the chain has failed. I believe they are smart led’s, all in series neopixel like.

It sounds like 1 LED in the chain has failed. I believe they are smart led’s, all in series neopixel like.

Exactly this, each LED has to pass data to the next, so if one fails everything in the chain after that stops too. Unless you have something like a hot air gun it’ll be difficult to repair yourself.

Could also be a fault on the circuit board, a break in a trace or something. If one had the skills and equipment it might be worth replacing that first LED in the chain that’s dark.
It wouldn’t be something I’d try myself as I was never trained in SMT stuff, and don’t have the tools to do it anyway. You’d need a heat gun, some patience and some luck lol.

Thanks everyone. I’ll try returning it to the place I got it from