Unsure on how to power Ubercorn

Hi there, I’ve got a Ubercorn and a raspberrypi zero, but I’m unsure on how to power them both.

I’m using an iPad pro power adapter with should supply 5v and 3A. That should be enough, right?

Here’s the specs for the charger:

On the product page it states the following, going by that your supply “should” work.

Power requirements: each Ubercorn panel will draw about 1A at 5V, meaning that a single Ubercorn should run fine from a standard 5V/2.5A Raspberry Pi power supply. You might just get away with running two from a single power supply. Larger setups will require additional power, supplied through the screw terminals on the rear of Ubercorn. Power can be daisy-chained from panel to panel (via the screw terminals), provided you have sufficient current to drive all of the panels.

Cool, so it should work, I’ve tried the examples but they didn’t work. Is there any way I can debug what’s happening?

I used the script to install everything, as well as rebooting the pi after enabling SDI

So the Pi boots up Ok etc, just nothing on the Ubercorn?
Did you solder the header on the Pi Zero?

Yup! I did the soldering on my own, but seems to be ok when I use the blinkt:

(Thanks for the help :) )

Blinkt pinout is here

I couldn’t find anything for the Ubercorn, not sure what pins it uses?

If you have time, could you post a good close picture of your soldering.
The only other thing I can think of is to check the setting of the ID jumpers.
Make sure its set to the default for one panel / first panel.

Here you go :)

I’ve also ordered a new ubercorn, just in case this is broken (I had it for a while, it was a gift, but only tried yesterday).

Thats not the best job but I have seen worse. Way worse.
I wish I knew what pins the Ubercorn used?
Some of those pins could use a resolder. You may be missing a ground connection thats needed or something.
Have a look see at this.

I would concentrate on the +5V, +3.3V, and any ground pins. And the two i2c pins.

Do you have another Pi, with a presoldered header? It would tell us if its the Pi or Ubercorn that has the issue.

In only have normal raspberrys unfortunately! Will wait for the new ubercorn to check :)

I’ll also retry the soldering :)

Sorry for the late reply. Turns out the panel is broken, it works with a new one :)

Bummer that it was broken. Nice to finally know what was broken though. Now you can have some fun. =)