USB port issue with Pi 3 B+


#1

Hello, hope someone can help me.

I’ve recently purchased the new rPi 3 B+ although I’m having issues using the USB ports, tried a bluetooth keyboard (which does pair with the USB dongle), wired keyboard and mouse. The USB ports have power, verified with a USB fan.u
I’m powering the rPi with an official power supply with HDMI to my monitor. Using the latest Raspbian Stretch OS image, the Pi boots up (nice and fast on this new model) to the Pixel desktop.

On boot I see the following messages (sometimes the messages don’t appear, and usb still doesn’t work), with or without a USB device plugged in (tested with each port). Plugging in the USB device after boot has no effect.

usb 1-1.1-port3: cannot reset (err = -71)
usb 1-1.1-port3: cannot enable. Maybe the USB cable is bad?
usb 1-1.1-port3: cannot disable (err = -71)

I have no issues using the same sdcard (and OS), power supply, HDMI and keyboard/mouse with with the older Pi 3.

Any assistance is appreciated.

Thanks,
Richard


#2

Sounds to me like it could be an issue with the Pi itself ,I would contact the seller for a return


#3

It could be worth trying to image a fresh copy of Raspbian onto another SD card to see if it makes any difference- but it does appear at a glance to be a problem with the hardware.


#4

Thank you for your help.

After explaining the issue to the seller they have sent me another Pi 3 B+. This Pi worked as expected using the same sdcard and peripherals. I can only assume it was a hardware fault.

Kind regards,
Richard