VolumeControl::init() - Failed to find mixer elements!



I put together my Picade this weekend using the hat and a custom box (with the sound running through HDMI, rather than the speaker), and everything seems to be running hunky dory. However I am having problems with RetroPie randomly reporting the error VolumeControl::init() - Failed to find mixer elements!.

When I set up my hat using the script on Github (https://github.com/pimoroni/picade-hat), I answered no to the question Would you like to use the speaker amp on the Picade HAT?, so I’d expect the HDMI output to work fine. Is there anything I can try to stop this random dropout?


then the script did absolutely zero to your audio config… in fact, if you had said ‘yes’ then you wouldn’t be able to play through HDMI at all.

… I am unsure why you receive these errors in other words, but no part of the Picade hardware, nor software setup (if you opted out of setting up the DAC) can be a factor in creating it.

I guess it could be the demand on the CPU if it is mid game. What Pi is this on?



I believe this is related to Retropie and it expects to find the alsamixer and when it doesn’t it produces this error. I have a similar problem if I use the phat dac with the Picade.




hum, your problem with the pHAT DAC would be expected - but can be resolved by dropping the asound we ship with Picade HAT in /etc/… that is its primary purpose, to create the PCM object RetroPie is looking for.

… as far as I’m aware, playing through HDMI does not require specific adjustments to ALSA configs, but I’d have to check. I guess it wouldn’t hurt to use the asound intended for the DAC but it shouldn’t be required.


It’s on a Pi 3. Weird that it seems to be happening randomly. Occassionally I’ll boot up and sound works perfectly. This is on menus and emulation BTW.


OK, so, if I understand right, it works on certain boot but not on others? consistently, as in if you have problems it will be constently from the start?

… I’m not sure if that will help, but it won’t hurt to ensure you force the audio through HDMI with:

curl https://get.pimoroni.com/audio | bash

and choose option 3.

That said I’m not sure that is your problem, but that is the only thing I can think of if behaviour vary from boot to boot.


Awesome, that seems to have sorted it, thanks!


Forgive me ahead of time for such a basic question… I’m having the exact same problem with my retropie… periodically sound pops in and out… then come back fine… then goes away when playing games… while watching through kodi it works fine… I’d like to try the suggestion from the link but I have no clue what to do… do I go to that site from somewhere on the raspberry pi itself or is it a change on the computer?.. again sorry for the basic question… just getting my feet wet in this stuff

Thanks again


Hi, i’m getting the same error but I’m not trying to run the audio through HDMI. here’s my setup:

RPi 3 Model B
SmartiPi Case
7" touchscreen for SmartiPi Case

i have an external volume control so i dont need any software controls. when i run anything (roms, videos, etc) the audio is great (way better than the built-in audio on the Pi) but when running Kodi the error “lvl0:
VolumeControl::init() - Failed to find mixer elements!” shows up at the top of my screen throughout any video. again, no actual problems with the audio. just the annoying error during video playback…

any ideas?


everything from retropie to kodi is up-to-date.


I think this is something to do with setting audio to come via PCM on the Pi…

In the Retropie menu set output to PCM…Set volume to 100%

Stopped this issue for me…