Xhat buttons/stick not detected

Hey everyone!

I just built my picade 10 on a 4b from an Adafruit kit, and I’m having trouble getting the controls to work. I can configure an external controller just fine, but nothing hooked up to the xhat aside from the power button works, and then the power button only turns the unit on, it doesn’t shut it down. I’ve followed the official instructional video and googled around with no luck. I’ve reseated the hat, checked all the wires and polarity, installed the xhat drivers, updated retropie to the latest, and everything else I can think of from my limited raspberry experience. I found a few other references online to this problem but they’re mostly for the pi 3, and they were all solved through either a better power adapter or finding out that the hat wasn’t seated correctly, and those are not the problem here. Do I have bad hardware? Did I miss a step?


Is it the new Xhat or maybe the older version of the Picade Hat?

I believe it’s the new version, it came with the picade 10 kit, it’s USB-C powered, I’d have to go pull it off the board again to check but I feel like there was some indication of it being a newer version printed on the back side too. Does that fit?

If it’s USB C its the newer XHat. Just wanted to make sure you weren’t running the new installer on an older version hat.

I’ve heard anecdotally that a better SD card might help somehow, and coincidentally I already ordered one and it arrived yesterday, so I’ll try loading the image on that and see if it works.

I ended up doing two things, one or both solved my issue (for the most part). The new SD card (a Samsung Evo, much nicer than the one that came with the Pi), and loading it with the Wolfanoz image, which I proceeded to update the heck out of. Somewhere along the line it started detecting the xhat buttons. There’s still plenty of wonkiness in how certain emulators interpret the buttons, but it’s a functional circuit now.