Blinkt! Puzzler

I have a real puzzler with the Blinkt! module:

On a Pi ZeroW:
Directly mounted – nothing, zilch
Jumpered from header to Blinkt! – works!

On a Pi 3A+:
Directly mounted – nada, zip
Jumpered from header to Blinkt! – works!
Mounted on Mini Black HAT Hack3r – works!

Have tried above with a second Blinkt! and get the same result…

Both are with fresh install of Buster and…

Is there something obvious I am overlooking?

Here is my simple test program:

#! /usr/bin/python3

from blinkt import set_pixel, set_brightness, show, clear
import time

while True:
for i in range(8):

I have a to ask the obvious, are you sure its plugged in right side up when plugged in directly?

Yes…plugged in with rounded corners matching the corners of the Pi

I just plugged in my Blinkt directly to the GPIO and ran the CPU load from the examples and it ran OK. Pi 3B+. I then plugged my Fan Shim in, that is soldered to a female header, and plugged my Blinkt in to that and all Ok. Its actually
Female header > Fan Shim > Pico Hat hacker > 90 Male header > Blinkt.
I don’t have any female to male jumpers.

That is a puzzler for sure??

Just ran this

from blinkt import set_pixel, show
from random import randint
from time import sleep

while True:
    for pixel in range(8):
        r = randint(0, 255)
        g = randint(0, 255)
        b = randint(0, 255)
        set_pixel(pixel, r, g, b)

from here

It’s actually a good test program and nice to watch.

Wish I could be of more help but mine is working just fine directly connected?


Thanks for checking…will try your program and see what happens 8-)

I doubt it matters but my Pi 3B is in a Pibow Coupe case.

Tried also on a Pi3B and same result…mounted nothing displayed, jumpered test program works…

Pressed down firmly on the GPIO pins?

It’s on nice and snug…as I said in the title it’s a real puzzler…

There must be a bad connection some place that open circuits when the board is flexed? Something like that? Plugging it in is applying a light pressure to something that doesn’t like it? Best guess anyway. The following link will let you e-mail Pimoroni. I’d put a link to this thread in the e-mail. Its a hardware issue not a software issue.

I get what you are saying but that doesn’t explain why the Blinkt! works fine when mounted on a mini black HAT hack3r but not when mounted directly on a Pi…I have two Blinkt! boards and several different Pi models and it is the same problem which ever board/Pi is used 8-(

Ok, if it works on the mini black hat its not what I was thinking? I only have the one Blinkt that has worked no matter how I hook it up. I have no idea what’s up with yours?

Guess it will remain as one of unsolved mysteries of the universe…

Just to make things more interesting I received a new Pi 4B…created new image of Buster, installed Blinkt! software, mounted Blinkt! board and it works! Popped Blinkt! board off and put it back on Pi 3A+, created new image of Buster, installed Blinkt! software and not working…good grief Charlie Brown!