Can't connect to micropython or provision Enviro Grow Pico W Aboard

I’ve had the enviro grow for a few weeks. I updated to the latest firmare when I initially set it up to water 1 plant, and it worked consistently and uploaded to adafruit io. Sometimes I would see red flash and wasn’t sure why. Yesterday I moved it in order to water multiple plants, which involved unplugging it and switching from usb to battery power. I couldn’t seem to get it going again. I should have paid more attention to the lights so I could give an accurate account of what I was seeing- I tried resetting / cycling power, and sometimes both lights would be on solid, sometimes i think it would be just the red light or just the white light. In any case I could tell something wasn’t right, it didn’t react to the poke button and didn’t seem to go to sleep either.
I disconnected everything and brought it over to my windows computer. I can’t seem to get thonny to detect it. I tried the “nuke flash” uf2 file, and then thonny was able to find it. When I try to reflash enviro firmware, it again appears undetectable to thonny, and it also doesn’t go into provisioning mode or anything. Both white and red lights are on and solid.

I’m not sure what to do… :'(
I was going to use this to care for my plants because I’m going to be away from home soon!