I tried to upgrade Enviro-Grow to “pimoroni-enviro-v1.21.0-micropython.uf2” and didn’t work ! Red Led and White led still on and unable to view files anymore with Thonny

I tried another cable and another MBP, same things.

So, flash_nuke.uf2 and restart the process, same things.

I upgraded Enviro-Urban as well and it’s working very well. Straight forward process and simple :)

Should I do something different for Enviro-Grow to upgrade ?

Best regards and thank you in advance !

You might find that you need to manually configure the port in Thonny, in case it’s managing to look in the wrong place. From the troubleshooting docs:

"You can do this by clicking on 'MicroPython (Raspberry Pi Pico) at the bottom right, and selecting 'Configure Interpreter'. Select your device under 'Port'."

If it were me, I’d be tempted to try the latest uf2 from the enviro repo itself (Releases · pimoroni/enviro · GitHub) - it’s older, but a definite “known working” so might help if something has crept into the latest 1.21 builds and not been caught yet.

I tried “pimoroni-enviro-v1.20.4-micropython-enviro-v0.0.10.uf2” as suggested and I notice the file is uploading… but red Led still on afterward. I configure Interpreter in Thonny and the status is : “no backend”. Unfortunetly it seems the enviro-Grow board doesn’t communicate with Thonny. The board doesn’t go Provisionning Mode either. White led turns on (still).

I tried DFU mode through Thonny,

Target Volume : /Volumes/RPI-RP2
Family : RP2
MicroPython : RP2
Variant : Raspberry Pi - Pico W / Pico WH
Version : 1.22.1
Info : MicroPython - Python for microcontrollers

Writing to /Volumes/RPI-RP2/RPI_PICO_W-20240105-v1.22.1.uf2
Waiting for the port…
Found port /dev/cu.usbmodem14201 (USB VID:PID=2E8A:0005 SER=e6614c311b717526 LOCATION=20-2)

Then I tried to run main.py and I get :

MPY: soft reboot
Traceback (most recent call last):
File “”, line 31, in
File “enviro/init.py”, line 9, in
ImportError: no module named ‘pimoroni_i2c’

RED led still on (steady)

I’m a little confused by the uf2 name; that looks to be writing a standard Pico Micropython, rather than the Pimoroni flavour - so yes, that would fail to run any Pimoroni code because it won’t have all the Pimoroni packages (like pimoroni_i2c) built in.

When I use one of Pimoroni UF2 files, like this one pimoroni-enviro-v1.21.0-micropython.uf2, I get « no backend », Thonny unable to communicate with the board and red led is always on.

I tried the last 3 versions of Pimoroni files.

Hmm; so a standard MicroPython works (in that Thonny connects) but the Pimoroni flavoured one leaves Thonny unresponsive?

Can’t say I’ve ever come across it; hopefully someone else has!

Your conclusion is exactly right! Thank you for time, really appreciated